Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have been using Ubuntu 11.10 for a couple weeks. I have 3 external hard drives attached to the system via USB. At present, they are set to read only. The file systems on them are NTFS. I have tried using pysdm, editing the fstab, etc. Nothing is working! Here is my fstab as it is now:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc                                       /proc           proc  nodev,noexec,nosuid                    0  0  
# / was on /dev/sdb5 during installation
UUID=84c3df14-0aba-4326-ac0f-c1a99e8749b9  /               ext4  errors=remount-ro                      0  1  
# swap was on /dev/sdb6 during installation
UUID=417c09b2-0282-47c3-a373-765f6af9fbb7  none            swap  sw                                     0  0  
/dev/fd0                                   /media/floppy0  auto  rw,user,noauto,exec,utf8               0  0  
/dev/sdc1                                  /media/sdc1     ntfs  nls=iso8859-1,umask=000,uid=steve      0  0  
/dev/sdd1                                  /media/sdd1     ntfs  nls=iso8859-1,umask=000,uid=steve      0  0  
/dev/sde1                                  /media/sde1     ntfs  nls=iso8859-1,umask=000,uid=steve      0  0  

This is really annoying me! I need to be able to use these drives! Any changes I make to the drive lines causes errors when I unmount then try to remount the drives. Can anyone help? Thanks!

share|improve this question

2 Answers 2

Did you install the OS with them connected? I haven't had to add anything to the fstab in a long time concerning the USB External Drives that are NTFS. You could try throwing a # in front of each line. Disconnect the drives. Then reboot. Once the system is back up try plugging them back in. See if that makes a difference. Make sure you have ntfs-3g installed too.

I always disconnect my ext. hard drives when doing a fresh install and then reconnect them after I boot the system up for the first time. Ubuntu should automatically recognize them and set it up for you. It sets all mine up for read, write, and execute permissions for my user. Unless there is a specific reason why you want them listed in the fstab, it is not necessary.

share|improve this answer
    
I added the drives a couple days after I installed Ubuntu. I just saw that ntfs-3g is a program. I'm installing it now. Thanks! Lets see what happens –  Stephan Smith May 1 '12 at 2:23

Have you seen this answer from askubuntu? This corrected my problems with USB flash drives under 10.10 and may work for you.

The summary is:

Disconnect your USB drives and then edit the USB disk rules file.

$ sudo vi /etc/udev/rules.d/90-usb-disks.rules

Add the lines:

# UDEV Rules to change the permission of USB disks
#

KERNEL=="sd*[0-9]", ATTR{removable}=="1", ENV{ID_BUS}=="usb", MODE="0022"

Then restart the service:

$ sudo /etc/init.d/udev restart

Now reconnect your USB drives.

share|improve this answer
    
Ok, here's what I just did. I shut down the comp, then unplugged the drives. I restarted, then went into the fstab and deleted the lines for the external drives, saved it, then rebooted. Once the comp was back up, I plugged the drives back in. That seems to have fixed it. I just wonder why the permissions changed in the first place?! –  Stephan Smith May 1 '12 at 2:40
    
Stephan, I'm not sure what caused the problem, but I had external (NAS drive) connection issues when I migrated to 11.10 so there must be some change to the /dev code that changed the way external devices permissions are handled. At least they are working for you now! –  Jim C May 1 '12 at 18:50

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.