Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This question already has an answer here:

I upgraded from 11.10 to 12.04 and now my launcher menu is missing. I opened terminal using CTRL+ALT+T and the menu shows but the GUI (bar) above that is missing.



Things like CTRL+TAB and image previewer don't work. I've tried whats mentioned here but no luck.

Another Screenshot of my GUI looks :

share|improve this question

marked as duplicate by minerz029, Eric Carvalho, BuZZ-dEE, Eliah Kagan, mikewhatever Jan 13 at 18:57

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

    
I don't think we ought to close this question, but I do recommend you report this as a bug. –  Eliah Kagan Oct 4 '12 at 21:20

11 Answers 11

Try executing this command in the terminal:

unity --reset

It resets your Unity.

share|improve this answer
    
I did try that. No change. –  anjanesh May 3 '12 at 3:51
2  
Worked for me. Thanks! –  drusepth Oct 19 '12 at 18:28
    
shows "deprecated" on ubuntu 13.04. Yes I know the question is about 12.04 :) –  arkilus Aug 24 '13 at 0:44

First, try sudo apt-get -f install && sudo apt-get --reinstall install unity

Then, try unity --reset, followed by unity --replace; try doing this from the desktop and also from the console (switch via Ctrl-Alt-F1).

share|improve this answer
    
of no help still missing launcher + menu bar –  Scott Stensland Jun 6 at 22:58

I think you are missing the indicators. Open a terminal window and type in the following to add the required packages:

sudo apt-get install indicator-applet-appmenu indicator-applet-session
sudo apt-get install indicator-applet-complete
sudo apt-get install indicator-application indicator-session 
sudo apt-get install indicator-power indicator-sound

I had installed a minimal Unity desktop on an Ubuntu Server image but that minimal desktop didn't have any of the top panel buttons for sound, shutdown etc.

Adding the above indicators restored everything after a logout or restart of Ubuntu.

share|improve this answer
up vote 5 down vote accepted

I got this resolved. Apparently the upgrade process wasn't through 100%.

I did the following commands:

sudo apt-get -f install
sudo apt-get update
sudo apt-get upgrade

And somehow after a restart it magically worked.

share|improve this answer

I had this problem for weeks and had tried the above recommendations. I was due to reload my box when I stumbled upon changing the resolution. My native resolution was 1920x1080 (16:9). I was launching firefox from terminal window and needed to double the resolution for a presentation I was watching. I changed to 1280:720 (16:9) and was surprised to see the left menu return. When I went back to 1920x1080 it was there again too.

share|improve this answer

I have used gnome (classic). After update to 12.04 any window or app window did not had task-bar with min/max buttons. I have logged off, on log off screen clicked on gnome/ubuntu sign and chose ubuntu and logged in and windows are backed to normal. Logged off again and switch to gnome (not gnome classic) and windows are normal.

share|improve this answer
    
This isn't an answer. It should be posted in comments. –  hbdgaf May 12 '13 at 20:39
    
@CallmeV, read it twice, he tells how he got it solved for himself :-) –  guntbert May 12 '13 at 20:50
    
@guntbert It doesn't fix gnome-classic so imo it's not an answer. If this is an answer the answer is use a different DE, which isn't an answer. –  hbdgaf May 12 '13 at 22:50
    
UPDATE: Ok,I tried today both "gnome" from menu and the both are fine. –  Nikola May 14 '13 at 0:05

I encountered the problem because of I installed the ia32-libs package yesterday (finding it wasted me a long long time)!

/usr/lib/nux/unity_support_test -p

After I executed the above command.

If you get the error message:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory

You may encounter the same problem with me. You can solve it by this way:

  1. Get the path of the 64bit libGL.so.1 by command locate libGL.so.1. For example, my path was /usr/lib/x86_64-linux-gnu/mesa/libGL.so.1.

  2. Add the path exclude the file name (/usr/lib/x86_64-linux-gnu/mesa) to /etc/ld.do.conf. Just start a new line.

  3. Execute the command sudo ldconfig

  4. Restart, and good luck.

PS: I'm Chinese and my English is very poor, so some words or sentences may make you confused. Sorry to all. I like this forum; I can get lots of assistance here. Thanks for your sharing and kindness.

share|improve this answer
    
your English is perfectly okay :) –  Jaroslav Záruba Mar 8 at 18:20

I got this problem too. I found that I had some packages that were kept back. I did an apt-get install on all these packages and now things work again.

share|improve this answer
1  
Running sudo apt-get dist-upgrade will also usually upgrade any packages that have been kept back. –  Eliah Kagan Oct 4 '12 at 21:18

I got rid of fglrx with sudo apt-get autoremove fglrx --purge and rebooted sudo shutdown -r now.

share|improve this answer

I had pretty much the same problem under 12.04. Unity was slow with my aged GPU, so I was using Unity 2d as my desktop for months. For no apparent reason, it suddenly refused to display launchpad and title bar (for all users). Reenabling Unity in CCSM as suggested here was part of the solution, but none of the other measures suggested here, there or in several other related threads, including, but not limited to:

  • Reinstalling unity

  • Reinstalling ubuntu desktop

  • Removing all relevant (e.g. compiz, gconf, etc.) configuration information

helped me to completely resolve these symptoms under 12.04 (64 bit).

unity --reset

would not work for me. After delivering a variety of error and information messages, it would always hang at:

Setting Update "run_key"

as shown in the log posted in the thread titled "unity has vanished" for unity run with no arguments.

I noticed that the error message delivered by:

/usr/lib/nux/unity_support_test -p

was similar to some of the errors reported by unity --reset:

error while loading shared libraries: libGL.so.1: cannot open shared object file: No such file or directory.

as reported by user139869 above. Unfortunately, his solution did not work for me. After extensive searching, I found the following solution:

  1. Get the path of libGL.so.1 by using the command locate libGL.so.1.

  2. Add a link to the library in /usr/lib/ as shown in the following example:

  3. sudo ln -s /usr/lib/i386/mesa/libGL.so.1 /usr/lib

    (courtesy of J.D. Bartlett)

  4. Restart the computer.

This not only allowed both unity_support_test-p and unity --reset to run, it also allowed Unity 2d to start. I have no idea what caused my problems, but since creating the links above (several weeks now) I have had no further problems.

share|improve this answer

Go to monitor Preferences: Select same image in all monitors

share|improve this answer
2  
How is that an answer to the question? He said nothing about multi-monitor. –  guntbert Jun 29 '13 at 16:28

Not the answer you're looking for? Browse other questions tagged or ask your own question.