Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

how to remove installed Xnoise, rhytmbox on my sound indicator? I am not using these 2 music player anymore I want to remove it

share|improve this question
add comment

4 Answers 4

up vote 12 down vote accepted

Currently, the only way to do this is to edit the seendb txt file that the menu uses to keep track of interested players.

Open terminal and type:

gedit ~/.cache/indicators/sound/familiar-players-db.keyfile 

This will launch the familiar text editor where you will see something like

DesktopFiles=/usr/share/applications/banshee-1.desktop;/usr/share/applications/rhythmbox.desktop;

Remove the rhythmbox and xnoise entries

and leave it looking something like

[Seen Database]
DesktopFiles=/usr/share/applications/banshee-1.desktop;

Save, then reload indicator-applet on the panel.

share|improve this answer
add comment

Rather than blacklist the entry, it can be removed from the list.

Try the following:

kch:~$ gsettings get com.canonical.indicator.sound interested-media-players
['banshee', 'rhythmbox']

This shows I have two entries. To remove one, use the set option:

kch:~$ gsettings set com.canonical.indicator.sound interested-media-players "['rhythmbox']"

Note the quotes around the value to be inserted.

Now restart or logout, and the entry should be gone from your sound menu.

share|improve this answer
    
This works like a charm on 11.10 Oneiric –  Nate Nov 19 '11 at 15:08
    
this is exactly what i needed. i had gnome-mplayer stuck in there after uninstall and this method solved that issue for me! thanks! –  nyne Sep 13 '13 at 0:51
    
you may still want to blacklist as i found rhythmbox somehow ended up appearing in the list again, despite me removing it –  Tom Carchrae Dec 29 '13 at 17:50
add comment

12.04

If you wish to hide or 'blacklist' a media player from the sound indicator, you will first need to make sure if the sound indicator settings have media players already blacklisted:

gsettings get com.canonical.indicator.sound blacklisted-media-players

If no other players have been blacklisted, you will not have to worry about adding them to the command below. If you do have other media players, you will need to copy those players into the below command and add any other players you want to backlist.

gsettings set com.canonical.indicator.sound blacklisted-media-players "['<mediaplayer>','<mediaplayer']"

Here is an example of how to blacklist spotify from the sound indicator:

gsettings get com.canonical.indicator.sound blacklisted-media-players
['']

gsettings set com.canonical.indicator.sound blacklisted-media-players "['spotify']"

gsettings get com.canonical.indicator.sound blacklisted-media-players
['spotify']

Hope this helps.

share|improve this answer
add comment

While the other answer didnt work for me with 11.04 Natty Narwhal I looked for another way. For example to remove rhythmbox from the sound-menue the following command in terminal worked:

gsettings set com.canonical.indicator.sound blacklisted-media-players "['rhythmbox']"
share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.