Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to 12.04 this weekend, and since the upgrade, whenever the screen is turned off (after 5 min of inactivity), the fan starts to run like crazy, making a lot of noise. When I get back to my computer and the screen is turned on again, it's silent again.

Obviously I can't see what's happening when the screen is off, but leaving top open in a terminal window, I see that compiz is taking 50+% of cpu right after the screen is turned on again. This seems quite an excessive load for compiz, given that the screen is off :). It quickly goes down to about 5% after that. There are spikes up to about 25% during normal use, but no excessive fan whirring noise.

Additional info: I have a Sony Vaio laptop with an i5 processor and an ATI Radeon video card. I have installed the Additional Drivers for the ATI card, but the problem also occurred when I hadn't installed them yet. I have a dual monitor setup with my laptop screen and a separate monitor connected through VGA in different resolutions. In the Catalyst Control Center, I have set the Display Manger settings to "Multi-display desktop".

I used this exact same set-up in 11.10 with no problems. Also, when I upgraded to 12.04, I did a fresh install, where I cleared the disk before installing Ubuntu. (Although I left the Windows partition intact.)

Any idea what migth be causing this, or, more importantly, how I can fix it? The sound of the fan when I'm not using the computer is really annoying.


(My problem seems to be related to this one, but in my case it only happens when the display is turned off, and also it didn't happen in 11.10, so this issue seems to be different enough to get its own question.)

share|improve this question

closed as off topic by jrg May 21 '12 at 21:12

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
I have filed a bug report (bugs.launchpad.net/ubuntu/+source/compiz/+bug/995118) on what I think is the identical problem. Maybe you can add that you are also affected. –  Andy May 5 '12 at 15:44
    
@Andy Thanks for the heads up! I added my support. –  jqno May 5 '12 at 17:25
add comment

1 Answer 1

Same problem. As a workaround I've installed XScreenSaver and it helps :).

share|improve this answer
    
Lol ... not really the solution I was looking for. But I'll give you a +1 for originality :). –  jqno Apr 30 '12 at 17:36
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.