Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have upgraded to Ubuntu 12.04 and I have a problem with the volume. The problem is that the volume is 0 when the volume bar is between 0% and 66% more or less, so the actual volume range is only between 66% and 100%. If I open the sound configuration menu, the position in the volume bar that makes the sound begin sounding (66% more or less) is placed where it says "no amplification".

Can anyone help me?

Thank you.

share|improve this question
    
What kind of output are you using, is it a digital toslink connection or analogue stereo? I had a similar issue when using optical, although it was the opposite where 0% was mute and everything above that was 100% unamplified. –  AyaneForever May 10 '12 at 19:41
    
I use duplex analog stereo and I have same problem as Alejandro. I tried other options but this is the only one where my microphone and speakers are working. In 11.10 everything was OK? –  Wojciech May 11 '12 at 8:44
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  hexafraction May 18 '12 at 20:09
    
@ Robert Arkenin : Way to help out!!!! From the websites name, I we all figured that if something in "Ubuntu" is having a problem, that we can ask for help here. If that is not what this site is for, then what????? Anyway, I somewhat have the same problem, it seems like if volume is set at 50% then, there isn't anything. You have to turn volume to like 90 or 100 to get 50%. But sorry Alejandro, I do not have any advice :( –  jredkai May 21 '12 at 9:44
    
@jredkai: The problem is that as a question and answer forum, this site is not really setup to track bugs. If there are workaround, we can post them, but other than that it is really best to submit a bug report to the project in question and follow it there. Please see this meta question for the reasons why. Also, please see my workaround to this bug below. –  Chris Jun 3 '12 at 7:07

2 Answers 2

This is probably due to a bug in alsa with the 3.2 kernel and the way it recognizes the hardware. As alsa gets is wrong, it cannot communicate correctly with Pulse Audio. It has been reported that this is fixed in the 3.3 kernel. In the meantime, the work around is to setup the hardware manually.

This is documented in the Ubuntu Community Help Wiki, but as the wiki claims to be outdated, and covers more that the problem at hand, the valid points are as follows:

  1. Edit the file /etc/modprobe.d/alsa-base.conf as root using the editor of your choice.
  2. Add the line options snd-hda-intel model=[Your Model Specifier] to the end of the file if it doesn't already exist. If this option is already specified, you simply need to change the model to the appropriate one.
  3. Save the file and Reboot for the changes to take effect.

The hard part is finding out which model to specify. You can find which hardware you are using with cat /proc/asound/card0/codec* | grep Codec at the terminal. If you get multiple lines of output you will need to determine which sound card is giving you trouble. You can then lookup the resulting hardware in the file /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz. As this file is compressed, you can uncompress it with gzip -dc /usr/share/doc/alsa-base/driver/HD-Audio-Models.txt.gz > HD-Audio-Models.txt this will create a new uncompressed file in the current directory.

The difficulty for me was that my hardware (Conexant CX20549 (Venice)) is not on the list. Evidently, this is the same as the Conexant 5045 so the Model Option Line for my hardware is: options snd-hda-intel model=laptop-hpmicsense. For those wondering, the hp-part in laptop-hpmicsense has nothing to do with the brand hewlet packard.

Once I put everything together, made the relevant changes and rebooted, everything works fine.

Thanks to user Rhino in http://askubuntu.com/a/140992/60904 for putting the last (and most important)piece to the puzzle together.

I hope this helps.

share|improve this answer
1  
Thanks, that was it. Works like a charm. –  Wojciech Jun 4 '12 at 12:41

Try checking the volume levels in alsamixer and pavucontrol (sudo apt-get install pavucontrol). That solved it for me.

share|improve this answer
    
In my case that did not help :-(( –  Wojciech May 28 '12 at 20:18
    
pavucontrol did the trick :) thanks. –  cognoz Dec 16 '13 at 13:14

protected by Community Sep 24 '12 at 15:42

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.