Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Ok, i realize I am not the only one, but I will try to provide all info possible to make it exemplary as possible and narrow down the error sources.

I have a fresh install of Ubuntu 12.04 and the suspend worked fine upon having it freshly installed but now it does not anymore.

The suspend option from the system power button on the top right works fine.

Things I did do which I don't know if they are related:

  • Install and remove againthe FGLRX drivers (Radeon graphic card)
  • Install Jupiter power managment (shutting it down is not changin anything)
  • Plug in and out an external display

The configuration I know of is well set:

  • In System Settings/Power all is set to suspend when closing lid
  • Double checked with dconf-editor, everything set to suspend

So, from here on I don't know how to proceed.. what are common problems that cause this error?

EDIT: My computer model is: Samsung Series 5 14" NP530U4BI

$ sudo lspci -nn
00:00.0 Host bridge [0600]: Intel Corporation 2nd Generation Core Processor Family DRAM Controller
00:01.0 PCI bridge [0604]: Intel Corporation Xeon E3-1200/2nd Generation Core Processor Family PCI Express Root Port 
00:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller 
00:16.0 Communication controller [0780]: Intel Corporation 6 Series/C200 Series Chipset Family MEI Controller #1 
00:1a.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #2 
00:1b.0 Audio device [0403]: Intel Corporation 6 Series/C200 Series Chipset Family High Definition Audio Controller
00:1c.0 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 1 
00:1c.3 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 4 
00:1c.4 PCI bridge [0604]: Intel Corporation 6 Series/C200 Series Chipset Family PCI Express Root Port 5 
00:1d.0 USB controller [0c03]: Intel Corporation 6 Series/C200 Series Chipset Family USB Enhanced Host Controller #1 
00:1f.0 ISA bridge [0601]: Intel Corporation HM65 Express Chipset Family LPC Controller [8086:1c49] (rev 04)
00:1f.2 SATA controller [0106]: Intel Corporation 6 Series/C200 Series Chipset Family 6 port SATA AHCI Controller 
00:1f.3 SMBus [0c05]: Intel Corporation 6 Series/C200 Series Chipset Family SMBus Controller [8086:1c22] (rev 04)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Thames [Radeon 7500M/7600M Series]
02:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6230
03:00.0 Ethernet controller [0200]: Realtek Semiconductor Co., Ltd. RTL8111/8168B PCI Express Gigabit Ethernet controller
04:00.0 USB controller [0c03]: ASMedia Technology Inc. ASM1042 SuperSpeed USB Host Controller
share|improve this question
    
We need more hardware information to help you, can you look at this question and then edit your question adding the information. –  Jorge Castro May 4 '12 at 0:31
    
Ok, is this what ok what i posted? –  dmeu May 4 '12 at 16:13
    
The model of laptop would be real useful too –  Jorge Castro May 4 '12 at 16:21
    
hehe, ok, put. I assumed it may be a common problem, doesnt seem so if it is dependent on all this information.. ? –  dmeu May 4 '12 at 22:48
    
Power management stuff is always hardware dependant, down to the specific model usually. –  Jorge Castro May 4 '12 at 22:49
show 1 more comment

2 Answers 2

I have this computer and have been having the same issue. Here's what I can add to this.

  • I can temporarily fix this by taking the bottom off of the laptop and pulling the battery and BIOS battery.
  • I can run Windows 7 and 8 for days without the issue coming back.
  • When I boot into either Ubuntu 12.04 or Mint 13 it will work for a while then come back. It seems to come back when I'm at home NOT while at work. Only difference that comes to mind is that @ home my WiFi supports WPS and work's does not. I'm going to test this further by not sing WiFi at home and see how long I can go. I know this sounds stupid, but it worked for days when I didn't use my laptop at home at night, but last night I connected to home WiFi and surfed Reddit and it broke again. I surf Reddit at work all the time and it lasted for days. Could be coincidence, but could be really weird bug.

  • Since clearing the BIOS fixes this I updated to latest BIOS, didn't help.

  • I have added Kernel 3.5 via PPA and did not fix

My Exact Model: NP530U4B-A01US http://www.samsung.com/us/support/owners/product/NP530U4B-A01US

Things I will test and report back.

  • I will swap out Intel Centrino Advanced N 6230 for a non-intel WiFi card (since 6230 support sucks anyway)
  • Not connect to home WiFi for a few days and see in Linux keeps sleeping on lid close.

More info:

I looked in my system logs for what I see when I close the lid all I get is:

[13888.253961] psmouse serio1: Touchpad at isa0060/serio1/input0 lost synchronization, throwing 2 bytes away.
[13888.764075] psmouse serio1: resync failed, issuing reconnect request

I get these same messages, and only these messages every time I close the lid.

share|improve this answer
    
intersting. please report anything else you get –  dmeu Sep 16 '12 at 15:09
add comment

Yes I'm experiencing the same issue with my Acer Aspire 7535G with a Radeon graphics card as well. This is the bug report I have issued: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/989674 Keep an eye on it for possible fix or support in the future.

In the time being do what I do to wake it back to GUI. Hit Ctrl + Alt + F6 to open a Ttyl terminal then hit Ctrl + Alt + F7 to reload the GUI.

Hope that helps!

share|improve this answer
    
my problem is somewhat different as the suspend option works perfectly but is just not invoked when i close the lid.. frustrating :-) –  dmeu May 4 '12 at 15:47
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.