Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I use keepassx as passwort manager and just moved from 10.04 to 12.04 with unity.

I would like that keepassx uses its tray icon. Unfortunally this option is greyed out in my installation. Several reinstallations did not change anything.

enter image description here

whitelist is set to [all].

Another bug seems to be, that keepassx does not show up in the unity bar when it is running. This leads to the problem that there will be multiple instances runnig when I try to open it via the dash.

Any fix for that? I could not find any!

share|improve this question

closed as off topic by Jorge Castro, Ringtail, maythux, Mitch, Stephen Myall Oct 16 '12 at 10:22

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
I have the same problem, here is the bug report: bugs.launchpad.net/ubuntu/+source/keepassx/+bug/992582 –  Dag May 17 '12 at 18:02

2 Answers 2

I think they disabled this feature. But you can compile keepassx from the sourcecode, that fixed it for me.

Remove keepassx via software center , apt or what you like. Go to www.keepassx.org and download the sourcecode. Extract the files and change into the directory. Open a terminal. Type:

qmake-qt4
make
sudo make install

You need the qt4 libs for this. Make sure you have the following packages installed:

sudo apt-get install libqt4-core libqt4-dev libxtst-dev

Now you can use the tray icon again.

share|improve this answer
    
Did not worked for me, same behaviour as before –  Dag May 19 '12 at 19:01
    
This did work for me, thanks. Ubuntu 12.04, unity. –  Ian Hincks Jul 3 '12 at 21:30

Enable precise-proposed repositories.

Then execute:

sudo apt-get update
sudo apt-get -t precise-proposed install bamfdaemon
sudo apt-get -t precise-proposed install unity

And restart.

share|improve this answer
3  
Maybe make a note about how this is only intended to solve half of the OP's question. Or am I missing something? –  Ian Hincks Jul 3 '12 at 21:31

Not the answer you're looking for? Browse other questions tagged or ask your own question.