Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

There was a tool to configure notifications in earlier versions of Ubuntu as described here. I tried to install it in Ubuntu 12.04 too but I failed.

I want to have the notifications dynamically located (e.g. notifications for music player and volume control will be shown at the same place) and to reduce the notification duration.

How do I change settings of notifications?

share|improve this question
up vote 88 down vote accepted

There is no official way of modifying the notifications, but many changes can be made to the notifications bubbles by installing a 3rd party patch which allows various changes to be made. More details are available here: http://www.webupd8.org/2012/06/closable-movable-notifyosd.html

To install:

Open a terminal window and enter these commands one by one:

sudo add-apt-repository ppa:leolik/leolik 
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install libnotify-bin
pkill notify-osd

This installs a patched version of the notify-osd package. Then you will need to install the GUI configuration tool, to do this enter these commands one by one into a terminal window:

sudo add-apt-repository ppa:nilarimogard/webupd8
sudo apt-get update
sudo apt-get install notifyosdconfig

To use the congfiguration tool type "notify" into the dash and launch the NotifyOSD Configuration application.

enter image description here

Modifying the Notifications

  • From this application you can change the colour of the notifications by clicking on the Background Colour box (in the picture below I've turned it a horrible green!).
  • To change the length of time the notifications appear on screen adjust the value in the Timeout box

enter image description here

The tool also includes other customisations including:

  • Change font, opacity, size, corner radius
  • Disable fade out
  • Close the notifications on click
  • Enable/disable "use Dash background colour for the notification bubbles"

Changing the position

To change the location that the notification appears you need to open a terminal and enter the following:

gsettings set com.canonical.notify-osd gravity #

the # in the above code should be replaced by a number between 1-6 depending on where you want the notification to appear (3 doesn't seem to work for me though):

1 - top-right corner
2 - middle-right
3 - bottom-right corner
4 - bottom-left corner
5 - middle-left
6 - top-left corner

enter image description here

  • In the Position drop down box you can choose from Fixed and Dynamic, dynamic gets rid of the gap between the notification bubble and the top dash
share|improve this answer
    
Bravo for this answer!! – jathanism Jun 16 '13 at 18:43
    
Thanks for this answer. The timeout box is enabled both on my machine and in your screenshot. Do you know how I can enable it? – Vitaly Mijiritsky Sep 14 '13 at 8:28
1  
It's important to note that the webupd8 PPA has many other packages in it, so it might be overwriting other packages... – MarkovCh1 Feb 23 '14 at 2:03
6  
A bit ridiculous that in 2014 you need to install a bunch of unofficial patches just to configure notifications, something that's a right click away on other OSes/desktop managers. – Dan Dascalescu Nov 12 '14 at 18:53
    
Only 2 works for me in the gsettings schema, Ubuntu 14.04 LTS :( – Serg May 6 at 19:39

I could not install notifyosdconfig using the PPA on my Ubuntu 15.04, but i got it working by doing the following:

sudo apt-get install bzr libqt4-dev
bzr branch lp:notifyconf
cd notifyconf
make
./notifyosdconf

Which does not fully install it (you won't be able to find it in the dash) but it does work.

share|improve this answer
    
This tools provides the same options and does the same, but is a different one from notifyosdconfig. Looks a bit different, seems to be its Qt4 port. A bit more information is here. – tanius Mar 12 at 15:21
    
Super Man , This is perfectly working in ubuntu 15.10 also...Thanks.... – salih kallai Apr 22 at 20:12

enter image description here

In my tool there are 3 Checkbox options at the end of Bubble tab which is not shown in previous answer's image, these options worked for me, I'll suggest U recheck the procedure of installation of this tool.

share|improve this answer
    
That was a year ago - 3/4 years ago Unity did not even exist - it probably just been updated. – Wilf Feb 19 '14 at 1:26

In case anyone might come to this question sometime with a Lubuntu distro (or any other of the 'Buntu flavors), please note that things might be quite different there. On Lubuntu, the best and quickest way is to use xfce4-notifyd-config; however, there is no way to have the notification dialog appear anywhere in the top center; merely the four corners are supported. But for those that don't need more, this will be sufficient by far to get the notification dialog out of the way when something else has been placed there and would constantly interfere resp. overlap.

share|improve this answer
    
Thanks for considering us Lubuntu users. After a year and a half, this answer deserves an upvote. BTW, the last sentence with “resp. overlap” isn't very clear. – Anthony Geoghegan Feb 18 at 22:05
    
If your xfce4-notifyd-config settings do not have any effect, it could be because Ubuntu's notify-osd is also installed – then, it will show the notifications, not xfce-notifyd. To fix this: sudo apt-get remove notify-osd and sudo killall notify-osd. – tanius Mar 12 at 14:44

protected by Community Oct 15 '15 at 17:15

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.