Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

To bring a window to the "top" via the mouse (ie. to bring it above other overlapping windows), I need to click on the window decoration.

Clicking anywhere else in the window, activates the window, but does not bring it to the top. Overlapping windows remain overlapped (obscuring the window I've just clicked on... until I click on the window decoration).
This mouse-click issue occurs with a maximized window too.

Keyboard actions like <Alt>+Tab work fine; the window comes fully into view.

This behaviour is the same for:
* Compiz window manager (with the GTK window decorator)
* Compiz window manager (with the Emerald window decorator)
* Metacity window manager

Is there some magic button to press to bring things back to normal?

share|improve this question

1 Answer 1

up vote 6 down vote accepted

In CompizConfig Settings, under General Options, check Raise on click.

If you don't have CompizConfig, install package compizconfig-settings-manager.

enter image description here

share|improve this answer
    
Well that was too easy... I've been looking for that pesky setting for weeks! ... Thanks so much.. :) ... but I don't quite understand how it still applied when Metacity was the manager.. maybe it was becasue this setting is passed on to the new manager.. (time passes) ... I just checked it in Metacity...yes "All systems are go!!" :) –  Peter.O Nov 12 '10 at 14:18
1  
To paraphrase von Neumann, "In gnome configuration you don't understand things. You just get used to them." –  msw Nov 12 '10 at 14:43
    
Awesome, thanks for putting this on here... I was looking for it to enable the very behavior the OP wanted to get rid of. :) Via la linux! –  dpb Aug 1 '11 at 3:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.