Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've just installed ubuntu 12.04 on my DEll v1450 laptop.

I downloaded and installed XAMPP 1.7.7

After that I created xampp control panel by using this command:

gedit ~/.local/share/applications/xampp-control-panel.desktop

File content:

[Desktop Entry]
Comment=Start/Stop XAMPP
Name=XAMPP Control Panel
Exec=gksudo “python /opt/lampp/share/xampp-control-panel/”
Name[en_CA]=XAMPP Control Panel
Comment[en_CA]=Start/Stop XAMPP

The file has "execute" permission already.

I tried to launch the launcher in Dash home but nothing appeared after typing my password.

What did I wrong here?

share|improve this question
up vote 5 down vote accepted

Try to run this command:

gksudo python /opt/lampp/share/xampp-control-panel/

And I got this error:

Error importing pygtk2 and pygtk2-libglade

Install python-libglade solved the problem:

sudo apt-get install python-glade2

Hope it's useful for someone.

share|improve this answer

This desktop-file seems right (I have almost the same). Maybe, you forgot to replace typographic quotes (as in your snipped) to normal quotes.

share|improve this answer

protected by Community May 31 '13 at 6:49

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.