Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I created ad hoc network in network manager. and set static ip address. When i am going to connect with other pc, its not connecting with that.

i followed this link enter link description here

    1. Right-mouse click the NetworkManager icon (top right)

    2. Select "Edit Connections"

    3. Click the "Wireless" tab

    4. Click "Add" to edit a new wireless connection

    5. On the wireless dialogue give the connection a name, e.g "Mochudi".

    *

    SSID: "Mochudi". The SSID will appear on the NetworkManager of your other Peers

    • Mode: Ad Hoc *

      BSSID: leave blank *

      MAC Address: leave blank *

      MTU: leave as automatic

      1. Click "Apply"

      2. Click "Close"

If fixed IP addresses are required edit the IPv4 Settings Tab before closing NetworkManager above:

...as above then...

6a. Click "IPv4 Settings Tab"

* Select Method "Manual"
* Under Addresses click Add
* Type your Address: 10.42.43.1
* Type the Netmask: 255.255.255.0
*

  Gateway: leave blank or 0.0.0.0 

6b. Click "Apply"

  1. Click "Close"
share|improve this question

2 Answers 2

in wpa_supplicant.conf file....

ap_scan=2
network={
ssid="gui"
key_mgmt=NONE
mode=1
 }

Can connect with non protected ad-hoc network using wpa_supplicant.

using this command....

wpa_supplicant -D **driver name** - i **interface name** -c **configuration file path** -dd

eg:

wpa_supplicant -Dwext - iwlan0 -c /home/xyz/Desktop/wpa_supplicant.conf  -dd  
share|improve this answer

if you are connecting windows pc's to the ubuntu ad-hoc network, if you set the ip address to 169.254.x.x and sub net mask to 255.255.0.0 the the pc windows machine will automatically connect to the ad-hoc netework. otherwise you have to setup all the individual pc's with their own static IP's.

share|improve this answer
    
i am using ubuntu as a pc to connect and using wpa_supplicant for establish the connection. But its not happaning... any help –  newbie1234 Apr 30 '12 at 12:53

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.