Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

The instructions in How do I set PATH variables for all users on a server? work to set the PATH for all 'normal' users. However, if I do sudo -s and then printenv PATH the updated path is not shown. I've taken a look at for example Setting TeX Live path for root, but this does not seem to make sense to me, perhaps as I'm from a Windows background. Is there any way to set the truly system-wide path, such that the entries are inherited by absolutely every process running on the system?

share|improve this question
add comment

2 Answers

up vote 6 down vote accepted

Update:

Setting global environment variables should still be performed in /etc/environment, but as you pointed out, using sudo -s has the effect of these variables are "vanished".

The reason for that is sudo has a policy of resetting the Environment and setting a secure path. It is enabled by default:

/etc/sudoers:

Defaults  env_reset
Defaults  secure_path="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin"

Thus whatever is set in the /etc/environment for the path is overridden by sudo.

The manual page for sudoers states:

   env_reset       If set, sudo will reset the environment to only contain
                   the LOGNAME, MAIL, SHELL, USER, USERNAME and the SUDO_*
                   variables.  Any variables in the caller's environment
                   that match the env_keep and env_check lists are then
                   added.  The default contents of the env_keep and
                   env_check lists are displayed when sudo is run by root
                   with the -V option.  If the secure_path option is set,
                   its value will be used for the PATH environment
                   variable.  This flag is on by default.

As a workaround, you can use sudo su that will provide a shell with root privileges but containing the right PATH.


Original Answer

You should set it in /etc/environment.

Try sudo YOUR_TEXT_EDITOR /etc/environment (make sure to create a backup first).

For more information: EnvironmentVariables

System-wide environment variables

Environment variable settings that affect the system as a whole (rather then just a particular user) should not be placed in any of the many system-level scripts that get executed when the system or the desktop session are loaded, but into

/etc/environment - This file is specifically meant for system-wide environment variable settings. It is not a script file, but rather consists of assignment expressions, one per line. Specifically, this file stores the system-wide locale and path settings.

Not recommended:

/etc/profile - This file gets executed whenever a bash login shell is entered (e.g. when logging in from the console or over ssh), as well as by the DisplayManager when the desktop session loads. This is probably the file you will get referred to when asking veteran UNIX system administrators about environment variables. In Ubuntu, however, this file does little more then invoke the /etc/bash.bashrc file.

/etc/bash.bashrc - This is the system-wide version of the ~/.bashrc file. Ubuntu is configured by default to execute this file whenever a user enters a shell or the desktop environment.

share|improve this answer
    
Ah well: to me this is all the wrong way around (everyone should inherit the same path, period), but I guess that's just how it is. –  Joseph Wright May 1 '12 at 7:48
add comment

sudo -i will simulate a login (in a similar way to sudo su -) and thus give you these environment variables.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.