Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
How to fix “The system is running in low-graphics mode” error?

I have an ATI Radeon 3200 graphics card.

I just upgraded to 12.04 and I get the System running low graphics... error code.

Your screen, graphics card, and input device settings could not be detected correctly.

It is exactly the same problem as one or two previous questions. So I tried their solutions to run sudo apt-get install ubuntu-desktop and sudo apt-get install fglrx

The only answer I get is You allready have the latest sw.

And my problem with System running low graphics... is still there. So what do I do? For the time being I run the previous version. It worked perfectly. Gunnar

share|improve this question

marked as duplicate by jokerdino, devav2, Stephen Myall, Mik, Amith KK Oct 19 '12 at 12:54

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

3 Answers 3

I have recently experienced the same thing, I have Intel based graphics card.

I fixed the following way:

Ctrl+Alt+F2 to go to a shell

sudo apt-get update
sudo apt-get -d install --reinstall gdm
sudo apt-get remove --purge gdm
sudo apt-get install gdm

Choose gdm when prompted.

Then do a shutdown -r now and voila.

Let me know if it fixed for ya.

share|improve this answer
    
thanks for the formatting :) –  user981916 Aug 29 '12 at 12:41
2  
I picked lightdm, not gdm (Xubuntu) and also did this: askubuntu.com/a/195805/64529 –  Marcel Valdez Orozco Oct 6 '12 at 17:53
    
You're my hero. –  Hassan Jan 17 '13 at 1:48
add comment

I fixed it by switching from lightdm to gdm. Press Ctrl+alt+F2, then login as root, then issue the following commands.

apt-get install gdm dpkg-reconfigure gdm

And choose gdm.

I thought it was a driver issue, but I'm able to use unity 2d now, with gdm, and with open source drivers. I reported a bug about it:

https://bugs.launchpad.net/ubuntu/+source/lightdm/+bug/993579

share|improve this answer
    
Thanks for the suggestion I tried it but the I got the answer " can't find dpkg-reconfigure" Have you got any idea what to do –  Gunnar Furugård May 10 '12 at 16:36
add comment

I found the fault myself. Somehow I had both the generic-pae kernel an the generic kernel. It seems as if my laptop cant handle the the -pae one. When I switched over to the generic one it works fine. Unfortunately the appeared as the default while the generic appeared in the previous version sektor. I used a tool "Grub Customizer" to get the generic one as the default. I tried to install 12.04 directly from a disk as well and when I did that I got the correct kernel as the default. I do not understand why it ended up wrong when I upgrade but correct when installed from the disk. Anyhow it works perfect now cheers Gunnar

share|improve this answer
    
The fglrx driver is built with DKMS. You need the linux-headers-<KERNEL VERSION> packages installed for being able to use these DKMS packages. To install the package for the currently loaded kernel, use sudo apt-get install linux-headers-$(uname -r). –  Lekensteyn May 21 '12 at 16:51
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.