Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Possible Duplicate:
What is the keyboard shortcut to minimise a window to launcher in unity?

I upgraded from Ubuntu 11.10 (with Gnome 3.2 I think), to Ubuntu 12.04 with Gnome 3.4.1, and my custom shortcuts have stopped working.

Opening up the All Settings -> Keyboard -> Shortcuts, I can see that my shortcuts are still there.

All of the shortcuts that I didn't change are working, and my shortcuts in the custom section are working (eg Ctrl+Alt+G to open gedit), its just that the shortcuts I had customised before the upgrade no longer work.

Under Launchers, I had changed "Launch Terminal" to Ctrl+Alt+T, and under Navigation I had changed move to workspace above/below to Shift+Ctrl+Up/Down.

Investigating further, it looks like the default shortcuts for these actions work (Ctrl+Alt+Up/ Down moves me up and down workspaces), so I'm guessing that there is some discrepancy between what I am seeing on the Keyboard Settings and what my computer is reading from.

Any help would be appreciated.

share|improve this question

marked as duplicate by RolandiXor, hbdgaf, Mitch, jokerdino, Jorge Castro Sep 2 '12 at 14:00

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

add comment

4 Answers 4

up vote 5 down vote accepted

Doug's answer on the question linked below enabled me to change the keyboard shortcuts on gnome-shell under 12.04. The short answer is to use dconf-editor (GUI) or gsettings (command line), rather than System Settings.

What is the keyboard shortcut to minimise a window to launcher in unity 12.04?

share|improve this answer
    
Specifically, under: org.gnome.desktop.wm.keybindings –  Tim May 31 '12 at 18:03
add comment

As answer 1 states this seems to be a bug in 12.04.

Fix announced for 12.10, see

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/965921

Tip: The Win Key is "<Mod4>"

share|improve this answer
add comment

If you use Gnome Classical, you need to install gconf-editor and follow the instructions from http://www.wiredrevolution.com/gnome/fix-alt-tab-task-switching-in-gnome-shell

Ubuntu is really a timewaster concerning these small annoyances.

share|improve this answer
add comment

It is nice and easy in 12.10.

Go to System SettingsKeyboardShortcuts tab → Map Keys here's some screenshots to make it as easy to follow as possible:

enter image description here

Click on this icon

enter image description here

share|improve this answer
    
Keyboard shortcuts keeps reverting to default ones, over and over again, since upgrade to 12.10. For instance, I like using only left hand to change workspaces, and assign Alt-{# of desktop}, instead of defult CTRL-ALT-{arrows}, which requires to use both hands and to let go the mouse. ¿Is there a way of saving the dconf entries somewhere and restore it from command line on every login? –  Awi Nov 8 '12 at 19:07
add comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.