Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just fresh installed Ubuntu 12.04 but using my old 11.10 /home partition as the /home point for the 12.04. (update: in other words, the 12.04 applications should most likely use my old 11.10 application configurations. actually they are.)

Weird thing is, I can not seemed to change the default saved directory for gnome-screenshot. I tried to change the saved location from ~/Pictures to ~/Pictures/Screenshots at the first screenshot. But in the second screenshot, the saved directory is still ~/Picture.

Here is the gconf.xml:

petra@petra-laptop:~$ cat .gconf/apps/gnome-screenshot/%gconf.xml 
<?xml version="1.0"?>
<gconf>
    <entry name="last_save_directory" mtime="1335771751" type="string">
        <stringvalue>file:///home/petra/Pictures/Screenshots</stringvalue>
    </entry>
    <entry name="border_effect" mtime="1335771746" type="string">
        <stringvalue>none</stringvalue>
    </entry>
    <entry name="delay" mtime="1335771746" type="int" value="0"/>
    <entry name="include_pointer" mtime="1335771746" type="bool" value="false"/>
    <entry name="include_border" mtime="1335771746" type="bool" value="true"/>
</gconf>

The screenshot should use the last_save_directory, right? (update: the unix timestamp shows 1335771751 which means Mon 30 Apr 2012 02:42:31 PM WIT GMT+7 few hours after I installed the 12.04, so this should means the gnome-screenshot successfully wrote the gconf.xml file)

And I also tried changing it from the CompizConfig Setting Manager, but also gives no luck.

Is there any other way to do it? (or should I report it to the Launchpad? I've never done it before, though)

update: Here's the fstab

petra@petra-laptop:~$ cat /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    nodev,noexec,nosuid 0       0
# / was on /dev/sda1 during installation
UUID=b7b72b03-f7e6-4665-a4cd-fa0df5b2a0cf /               ext4    errors=remount-ro 0       1
# /home was on /dev/sda7 during installation
UUID=6c4d7a04-1e5f-4514-98a9-3e37867b34e8 /home           ext4    defaults        0       2
# swap was on /dev/sda6 during installation
UUID=5ecd35ad-d3bf-482c-bdac-dc3eae31ee8e none            swap    sw              0       0

update:

I just tried capturing few screenshot and saved it to other directories instead of ~/Pictures/Screenshots. Apparently the gconf.xml wasn't updated after the latest screenshots.

share|improve this question

closed as off topic by desgua, fossfreedom May 9 '12 at 15:24

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are you using Unity or Gnome-Shell? –  fossfreedom Apr 30 '12 at 9:06
    
I am using Unity –  Petra Barus Apr 30 '12 at 9:13
1  
Mine is a "clean" install of 12.04 with a new (and just the one /home) and I see something similar. Pressing printscreen to take a screen shot always suggests ~/home/Pictures as the default save location no matter how many times I select ~/home/Desktop. Interestingly, if I run gnome-screenshot -i from a terminal (to use the time delay), it suggests saving to ~/home/Desktop! –  user25656 Apr 30 '12 at 10:09
3  
Same problem here. Seems to be a bug: bugs.launchpad.net/ubuntu/+source/gnome-screenshot/+bug/977228 –  Aibara Iduas May 6 '12 at 4:05
1  
possible duplicate of Default save directory for gnome-screenshot? –  desgua May 9 '12 at 15:10

Browse other questions tagged or ask your own question.