Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded to Ubuntu 12.04, and my wireless connection disconnects every 30 seconds. I am using an Asus Eee PC with an Atheros wireless card. I tried to find out how to solve this, so I gave up and rebooted my computer. Now the touchpad doesn't work. I tried to do a system restore, and it won't even start. The netbook goes straight to the login page. I'm going to have to switch to another Linux distro or use an older Ubuntu distro, because this is not working. I am not a skilled computer programmer, so I don't know what to do.

share|improve this question
    
I'm using a netbook, so I can't use a live CD. And my bootable flash drive is corrupted for some strange reason. This wireless problem happened immediately after the upgrade. I'm sure something went wrong with the upgrade. –  Lisa Apr 30 '12 at 6:14
    
Check for any additional drivers that are missing . –  senthilkumar Apr 30 '12 at 11:04

4 Answers 4

up vote 3 down vote accepted

I Had the same issue after upgrading to 12.04 where the Wireless connection was dropping every 30 secs.Here's what I did . Right click on the Wireless Icon on top of your screen ->Edit Connections -> Wirelss . Then Click on your Wireless Connection and Click on Edit the Wireless Security , Check the Available to all users box , make sure that the Network Key is entered , save the setting and come out . This fixed my problem. hope this helps.

share|improve this answer
    
It does help! Thank you so much. And I thought I was computer savvy.... –  Lisa May 4 '12 at 3:34

Try disabling power management for your WiFi NIC:

example for eth1: sudo iwconfig eth1 power off

share|improve this answer
    
codeError for wireless request "Set Power Management" (8B2C) : SET failed on device eth1 ; No such device.code Nothing happened –  Lisa Apr 30 '12 at 6:16
    
Try BartB's suggestion with wlan0 rather than eth1, so: sudo iwconfig wlan0 power off (Right click on the wifi icon and look at connection information to find the name of your connection) I had a stack of problems initially with 11.10 on an eeepc 901, wifi was one of the issues, but I can't remember how I solved it. Good luck –  user58656 Apr 30 '12 at 10:58

I had the same problem during last few days after upgrading to ubuntu 12.04. Problem solved as if it were a windows, but not ubuntu: Downloaded this: http://linuxwireless.org/en/users/Download/stable/#compat-wireless_3.4_stable_releases and do something like this: http://linuxwireless.org/en/users/Download#Recommended ; Then I deleted my wi-fi connection from the wi-fi list in network manager, found it again and connection dont drops now. good luck, sorry for my english.

share|improve this answer

I had the problem on a Toshiba Equium. Resolved by making a wired connection to my router and activating Update manager. 50MB downloaded automatically, incuding Kernal 3.2.0.24 Rebooted and normal wireless service was resumed.

Hope this helps.

share|improve this answer

protected by Community May 3 '12 at 10:03

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.