Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I just installed fresh ubuntu 12.04

I was succesfully compiled dosemu-1.4.0, unfortunately didn't work (it worked in ubuntu previous version). Looking to the ~/.dosemu/boot.log I found this weird messages:

MFS: dos_gen: path_to_ufs '/home/bambang/.dosemu/drives/c//command.com'
MFS: dos_fs: build_ufs_path result is '/home/bambang/.dosemu/drives/c/commndd.com'

Notice that command.com is mangled to commndd.com, very strange.

Searching in google I found the same error: http://sourceforge.net/tracker/index.php?func=detail&aid=3440083&group_id=49784&atid=457447

A comment in above page suggest that the error is due to glibc which has been fixed here: http://permalink.gmane.org/gmane.comp.lib.glibc.alpha/15674

ldd --version on my computer shows:

bambang@pa-o1-20:~$ ldd --version
ldd (Ubuntu EGLIBC 2.15-0ubuntu10) 2.15
Copyright (C) 2012 Free Software Foundation, Inc.
This is free software; see the source for copying conditions. There is NO
Written by Roland McGrath and Ulrich Drepper.

How do I upgrade the glibc version?

Thank you.

share|improve this question

closed as off topic by Jorge Castro, Marco Ceppi Apr 30 '12 at 15:29

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here. If this question can be reworded to fit the rules in the help center, please edit the question.

Welcome to Ask Ubuntu! This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Apr 30 '12 at 2:22
Thanks. Bug is reported –  Bambang Pranoto Apr 30 '12 at 4:37

Browse other questions tagged or ask your own question.