Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I installed Ubuntu 12.04 on my laptop, and am now trying to get it to run. In the grub menu, if I load it normally, all I get is a black screen. In order for it to boot successfully, I have to edit the menu item and add 'nomodeset'. With this, Ubuntu boots up.

Is there a fix for this, so that I don't have to constantly add the nomodeset? I tried to install the proprietary drivers but I still had the same problem.

My laptop specs are:

Intel Core i5-2410M (2.30GHz, Dual-Core)
6GB RAM
750GB HDD 7200rpm
AMD Radeon HD 6630 1GB

share|improve this question

1 Answer 1

You can edit the default grub boot options by typing in the terminal:

gksudo gedit /etc/default/grub 

Look for the line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

and add nomodeset to the end:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash nomodeset"

That way you won't have to keep adding it. Then after saving changes and quitting the editor, type in the terminal:

sudo update-grub

to update your grub configuration.

share|improve this answer
    
Ah thanks Chan-Ho Suh, forgot the update-grub! –  labarna Apr 30 '12 at 2:08

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.