Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I plug my headphones in after upgrading to ubuntu 12.04, it no longer mutes by speakers,and I also do not have a headphones output as I did previously. I recall having to go into a conf file and disable FRONT PANEL AUDIO or something like that; and everything began to work fine. I have an HP DV6.

Is there anyway to see what my alsa-base.conf was before the upgrade?

share|improve this question
    
can you look at this Q (not the accepted one) to see if the suggestion works for you? askubuntu.com/questions/100/… –  fossfreedom Apr 29 '12 at 21:44
    
I tried both: options snd-hda-intel model=auto options snd-hda-intel model=dell-m4-3 enable_msi=1 and got nothing... –  Frank Barcenas Apr 29 '12 at 22:06
    
I'm suffaring a lot with this same problem. I've reported a bug here--> bugs.launchpad.net/ubuntu/+source/alsa-driver/+bug/995684 Please go to the above link and support me one this bug to be solved. thanks. –  Kaziweb Jun 10 '12 at 23:18
add comment

5 Answers

up vote 5 down vote accepted

I placed:

options snd-hda-intel model=hp-dv5

options snd_hda_intel model=hp-dv5

In my /etc/modprobe.d/alsa-base.conf

I don't know which syntax is the correct one, but I left them both in for good measure.

I did NOT restore my heaphones option, however it did mute the speakers when I plugged in my headphones and that was good enough for me.

share|improve this answer
    
for me adding it to asla-base.conf is not working. my model is y410=lenovo-3000. not only it is working but it disables my sound card causes the playback through dummy output. After I deleted the extra entry I could get back my sound though the problem of head set working with speakers still persist... Ow forget to tell. after the restart now sound is coming through headphone alone, when unpluged no sound through the play throug device...(s/pdif). in ubuntu 11.10 it was analog out. I want analog out back.. any way? –  rjkrocks May 1 '12 at 2:01
    
then this might work for you: bugs.launchpad.net/ubuntu/+source/linux/+bug/477226 –  Frank Barcenas May 1 '12 at 13:24
add comment

In a terminal execute alsamixer then with the arrow keys go to the column "Auto-Mute", once selected set with the up arrow the option "Enabled".

Seems like the interface to my alsamixer is a bit different, but using the M key on my speaker changed a previously mysterious (grey-ed out) MM to ungreyed out 00 and re-enabled the speaker. The secret was definitely alsamixer.

share|improve this answer
add comment

I was having the same problem...

I updated from Ubuntu 11.10 to 12.04 and my frontpanel stoped working. The sound was only coming out from the rear panel.

I opened the terminal, typed alsamixer and pressed ENTER

Inside the Alsa mixer, I pressed right arrow until I get to an option called "Loopback Mixing". It was disabled... Enabling it solved my problem.

Hope it solves to you too!

share|improve this answer
1  
I don't have anything like that in mine. –  Frank Barcenas Jun 27 '12 at 3:34
add comment

Add ppa:diwic/hda repository to your sources

Are "PPA's" safe to add to my system, and what are some "red flags" to watch out for?

sudo apt-add-repository ppa:diwic/hda

sudo apt-get update

sudo apt-get install hda-jack-retask

Run hda-jack-retask from terminal

check set model=auto

click install boot override

reboot and you are ready.

tested on ubuntu 12.04 with realtek alc888 chipset.

share|improve this answer
add comment

Laptop/PC - Lenovo 3000 Y410 Issue - Headphone don't mute speaker in Ubuntu 12.04 LTS.

I had faced above problem and successfully resolved with solution covered in following page. https://wiki.ubuntu.com/Audio/UpgradingAlsa/DKMS This may help your situation.

I had tried all of following without success.

  1. Playing with alsamixer

  2. Adding various options in /etc/modprobe.d/alsa-base.conf

  3. Configuring with utility pavucontrol

share|improve this answer
    
I had this same problem in the same Laptop. Solved it now. askubuntu.com/a/150959/61218 –  Anwar Shah Oct 14 '12 at 17:59
add comment

protected by Community Oct 27 '12 at 15:48

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.