Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My unity crashed during the update from 11.10 to 12.04, and after waiting a long time i was forced to restart the computer. when it came up, things were in a sorry state, i got to the terminal and ran sudo dpkg --configure -a and it seemed the update resumed. after a reboot, everything seemed ok, except when going to the applications launcher, there a search bar for applications, but no filter results button, and searching for apps yields no results. there are also error messages that pop up about the unity application lens having a serious issue.

share|improve this question
add comment

2 Answers

The answer got from here

None of these fixes worked for me. But after more searching:

rm ~/.cache/software-center -R

worked like a charm. I did need to run:

unity --reset &

afterwards though, for the changes to take effect within dash, but the software center just started working straightaway.

The disadvantage: you need to reset your unity-related shortcuts

Some users found that it was not necessary to reset unity with its associated loss in shortcuts. A restart of X was sufficient.

share|improve this answer
add comment

i may have found the answer:

https://answers.launchpad.net/ubuntu/+source/unity/+question/156829

I copy/paste the solution given:

"Here's a summary, for those experiencing the same problem. In short, we're not sure action originally led to this problem, but somehow at least two packages were inadvertently uninstalled: unity-place-applications and unity-place-files. The removal of these packages seems to cause Unity to seemingly forget what applications were installed (and probably what files as well). Zeitgeist seems to still work, and remembers newly installed packages.

To fix the problem, simply reinstall the unity-place-applications and unity-place-files packages, then restart just to be safe."

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.