Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

This question already has an answer here:

I'm having issues installing Ubuntu 12.04 on my laptop. I downloaded the ubuntu 12.04 ISO and made a bootable USB. The USB works fine on my desktop computer, but I have issues getting it to work on my laptop.

On the laptop, the Ubuntu screen comes up and it gives me options:

  1. Run Ubuntu from this USB
  2. Install Ubuntu on a Hard Disk
  3. Test memory
  4. Boot from first hard disk
  5. Advanced options
  6. Help

If I select option 1, a bunch of lines come up and then all I get is a black screen and it does nothing. When I select to install Ubuntu, all I get is the black screen. I've waited 5-10minutes and nothing happens. As I said, I have no issues running the same USB on my desktop.

My laptop specs are:

Intel Core i5-2410M (2.30GHz, Dual-Core)
750GB HDD 7200rpm
AMD Radeon HD 6630 1GB

Any ideas why this is happening?

Note: Both computers have windows 7 already installed on them.

share|improve this question

marked as duplicate by Jorge Castro, Mik, Eliah Kagan, Eric Carvalho, Uri Herrera Mar 3 '13 at 4:28

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

Try the F6 option of nomodeset – Shannon_VanWagner Apr 29 '12 at 20:51
Look here:… – joelalmeidaptg Apr 29 '12 at 22:01

Try Shannon_VanWagners tip, to use the F6 option of nomodeset.

What you can do too is, interrupt grub, hit e to edit an entry (boot option 1), remove the splash and the quiet option from the kernel line, so you can see what it is doing. b should boot the modified entry.

Another idea to handle the problem: Boot from CD, mount the drive, and read the logfiles in /var/log/*log. Maybe this is possible from the grub-menu without booting from CD.

share|improve this answer

I had the same problem with an Asus computer and a Nvidia graphics card.

After searching in several forums, I tried everything and nothing worked for me and I didn't find the answer. After trying different options I changed the file syslinux.cfg in my pen drive enabling the ui gfxboot bootlogo deleting the #.

After that I rebooted my computer and began again but now with the other graphic interface. With F3 changed the language, F4 keyboard and WOW! F6 marked the nomodeset option and bingo it worked for me in a x64 machine and amd64 installer from a pendrive.

share|improve this answer

Try adding the nolapic or acpi = off boot parameters when you boot.

If it worked and you want to apply it permanently ,disable the new card (BIOS) or disable ACPI (also from the BIOS). But check if you have a Windows Recovery environment present on your laptop. Use the second option if you can't find the New Card Interface.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.