Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

My wireless connection has lost stability after I upgraded from Ubuntu 11.10 to Ubuntu 12.04. It used to remain connected for as long as there was signal, but now I get periodic disconnects which appear very random and without a defined cause.

I have attached an image (below) of a signal graph (graphed by iwScanner) which shows how signal is relatively stable but it is somehow lost momentarily and quickly regained.

iwScanner signal graph

You can see how there are short interruptions in the signal that cut the connection, which I assure you, are not caused by my router.

My network card is a Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01), in case it is relevant.


Test information

I had thought that the cause of this problem was either my network management application or the wireless card driver, so I decided to find out and tried the following configurations:

  • wicd with my same wl driver. This does not fix the problem, the behavior stays the same.
  • wicd with the b43 driver. With this configuration, I can't even connect to internet - wicd reads no networks in range.
  • nm-applet with b43 driver. This does not fix the problem either.

(My original configuration was nm-applet with the wl driver)

Also, I think the wl driver is also called sta.

Because of the outcome of this tests, I would conclude that the problem is not in the network management application nor in the driver. Where else could it be?

share|improve this question
The command lspci gave me this: 09:00.0 Ethernet controller: Marvell Technology Group Ltd. 88E8040 PCI-E Fast Ethernet Controller (rev 12) and this 0b:00.0 Network controller: Broadcom Corporation BCM4312 802.11b/g LP-PHY (rev 01) – Severo Raz Apr 29 '12 at 22:31
up vote 9 down vote accepted

Disable IPv6

Possible answer By the question's author, credit for user Captine.

I noticed this question on the Related sidebar, and one of its answers seems to solve my problem: Disabling IPv6 connectivity.

I have set the Network Manager applet to ignore by all means IPv6, but perhaps what was causing the problem was that my connection was changed by the upgrade so that it required IPv6 addressing before it was considered completed.

Connection settings

Of course this does not seem like a perfect solution (or even permanent), now that even though in my country IPv6 is still not a standard, it will someday be and I would like to have a continuous connection by then. For those whose ISPs provide only IPv6 connectivity, this is not a solution.

I have had a continuous connection for a long time now: enter image description here

If I have no interruptions for the whole day, I will make this an answer and consider this question closed. Of course, this question might be a duplicate of the one I linked - the opinion of a moderator is pending.

share|improve this answer
Had the same issue, my particular scenario is that I'm running Ubuntu 14.04 LTS on MacBookPro 11.3 (thus using BCM driver) if anyone else has the same issue. This solved the problem for me. – goten Feb 3 '15 at 20:03

My laptop has a Broadcom 4313 chipset which uses the same driver as yours. One thing I observed is that, when there's sustained and relatively high network traffic, the link will go down for about 10 seconds every 2 minutes. This is because the driver scans for access points every 2 minutes, but can't do this if the link is up; it thus brings the link down, scans, and brings link back up.

I'm not sure why this happens but a workaround I found is

  1. Find the hardware address for your access point. One way to do it is to use the iwconfig command and look where it says "Access Point:". It will have an address looking like AA:BB:CC:DD:EE:FF.
  2. Open the Networks indicator, then go to Edit Connections
  3. Select your wireless connection , press Edit, and on the BSSID field (NOT SSID), put the hardware address from your access point. Then save the connection.

I think what happens is, if the BSSID is configured, the driver knows the router's MAC address and doesn't need to go trying to find it every 2 minutes. If it's not configured, all it knows is the SSID and needs to check the MAC address, and for some reason wants to do it constantly.

share|improve this answer
Your solution didn't work for my case :/ I was so much hoping otherwise. – Severo Raz May 1 '12 at 1:37
Sorry to hear that :( I'll let you know if I think of something else. – roadmr May 1 '12 at 14:35

I once had similar problems with a Intel ipw2100 chip. The problem was solved by choosing a different IRQ in the BIOS.

I don't know whether this might help you, but perhaps if no other idea is comming, you could give it a try.

share|improve this answer
I think my BIOS does not have the option to access IRQ related settings. Its from a Dell XPS M1530 with BIOS version A12. – Severo Raz Apr 30 '12 at 0:06
I can't tell you, I don't have a Dell, but linux-on-laptops is most of the time a good idea to look for compatibility issues. – user unknown Apr 30 '12 at 0:18

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.