Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

With 11.10 I can use Unity 3D without problems, but with the upgrade to 12.04 ubuntu only uses Unity2D. I installed the free drivers for radeon, force the use of Unity3D and now it almost "works"... but now I have this problem: Screenshot of my computer

I tried to modify compiz settings but, everything is as bad as default...

My specs are:

  • Ubuntu AMD64 11.04. Clean install.
  • ATI Radeon 2100

lspci -nn | grep VGA
01:05.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Radeon 2100 [1002:796e]

$ /usr/lib/nux/unity_support_test -p 
OpenGL vendor string:   X.Org R300 Project
OpenGL renderer string: Gallium 0.4 on ATI RS740
OpenGL version string:  2.1 Mesa 8.1-devel (git-6af4c90 precise-oibaf-ppa)

Not software rendered:    yes
Not blacklisted:          yes
GLX fbconfig:             yes
GLX texture from pixmap:  yes
GL npot or rect textures: yes
GL vertex program:        yes
GL fragment program:      yes
GL vertex buffer object:  yes
GL framebuffer object:    yes
GL version is 1.4+:       yes

Unity 3D supported:       yes
share|improve this question
1  
you have installed an updated mesa - why? what happens if you try ppa-purge this and then reinstall the recommended ATI graphics driver as suggested in the Additional Drivers window? –  fossfreedom Apr 29 '12 at 19:47
    
It never suggest any additional driver as in older releases... And I'm very confused. I tried Fedora 16 (LLVMpipe), openSUSE (ATI RS740), and both work perfectly... –  estebarb May 14 '12 at 0:57
    
This question should instead be filed as a bug report, and as such is off-topic, thanks! Instructions on filing a bug report are here. –  fossfreedom May 14 '12 at 10:53
add comment

closed as off topic by fossfreedom May 14 '12 at 10:54

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

Browse other questions tagged or ask your own question.