Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am a first time user of Ubuntu. I have installed Ubuntu 12.04 dual boot with Windows. Ubuntu is screwing up the Windows clock. I looked this up and found the following lines to use:

  • gedit /etc/default/rcS (in Terminal)
  • UTC=no (in edit tool)

However, the rcS file will not save. The editing tool won't let me to save it. The editing program says I do not have permission. I am a noob. If there is a clear guide on how to get permission to edit and save rcS, step by step with actual command lines if possible, please direct me to it. If there is a very quick way to get permission to edit this file prior to editing, please let me know.

share|improve this question
    
Can't modern versions of Windows finally cope with UTC in the hardware clock? Windows's insistence on a timezone-dependent clock is annoying when you travel between timezones or have a computer that's not turned off during DST changes. –  Gilles Apr 29 '12 at 18:54

1 Answer 1

System files cannot be edited by users directly. They belong to the root user. One way to run gedit as root is to invoke it as root:

gksudo gedit /etc/default/rcS

See also Gedit command line tips and Graphical sudo in the Ubuntu community documentation.

By the way, note that it's rcS (with a capital S) and UTC=no (with UTC in uppercase). Under Linux, unlike under Windows, file names and variable names are case-sensitive.

share|improve this answer
    
Thanks both. I will look into changing Windows as well as learning more about accessing root user. I preferred knowing how to manipulate Ubuntu, so this answer was much appreciated. –  Karen Michaud Apr 29 '12 at 19:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.