Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a problem where Ubuntu (12.04) says there is a wireless network card, but it is disabled by a hardware switch. How do I turn it on?

I checked the BIOS, and the wireless card is enabled there.

Fn + F2 was also no success.

The results of rfkill list:

0: brcmwl-0: Wireless LAN
        Soft blocked: no
        Hard blocked: yes
1: dell-wifi: Wireless LAN
        Soft blocked: yes
        Hard blocked: yes

sudo rfkill unblock wifi did nothing to the Wireless Status.

share|improve this question
    
Fn + F2 didn't work, and my computer doesn't have a physical switch on the outside, which is why I asked here. –  lowerkey Apr 29 '12 at 18:45
    
sometimes this can be solved by booting into windows, enabling your wireless (Fn+F2) before booting into ubuntu. Can you try that? –  fossfreedom Apr 29 '12 at 19:25
    
Do you by any chance have Intel Centrino Wireless-N 1000 as your wireless adapter? –  new_bie Apr 29 '12 at 19:30
    
@saurabhshankar: how do I find that out? –  lowerkey Apr 29 '12 at 19:40
    
unfortunately, booting into windows isn't an option :( –  lowerkey Apr 29 '12 at 19:40
show 3 more comments

11 Answers

Try shutting down (if not already off), disconnecting the power, remove battery (if it is a laptop), press power a few times to release stored energy, reinsert battery (if it is a laptop), reconnect AC power. Turn on computer. Worked for me.

After trying multiple fixes I found on the internet I remembered reading this somewhere. My hardware was blocked via a hardware switch (Fn + F8) which doesn't work in Ubuntu (works with Windows).

rfkill showed 0: phy0: Wireless Lan as Hard Blocked.

share|improve this answer
    
Someone tried to edit my post adding the following info: Yes, this worked! Dell laptop 14z, Ubuntu 11.10. Some background: no h/w wireless switch, no BIOS wireless control. None of the handful of recommended commands worked. Booting into Windows is no longer an option. Only pulling the power worked for me. should have been a comment as the edit was rejected –  Askme Later Jun 5 '12 at 22:30
    
Following @jJorgeCastro's Solutions worked for me too. Second time.. weird!! –  Bijay Rungta Jul 18 '12 at 14:06
    
Removing battery + disconnecting and pressing power worked for me too! Now the battery is back and Inspiron 1710 reacts correctly to switching the switch. Ubuntu 12.04. –  savick01 Jan 13 '13 at 0:24
add comment

I found out by trial and error that the wifi hardware switch on my Dell XPS 17 L702X is not Fn-F2, as implied by the keyboard icon (and works in Windows), but actually Fn-Alt-F2 in Ubuntu. It might work for your Dell too.

share|improve this answer
    
great, this answer helped me! It does go for the Dell Vostro 3460 as well... Not only for the antenna switch, but also for the touchpad :) –  Koen Sep 18 '12 at 20:26
    
Glad I could help! It's strange though, because on my XPS 17, the touchpad switch works as normal (Fn-F3), and as implied by the keyboard icon. I've no idea why the inconsistencies... –  Sparhawk Sep 19 '12 at 0:37
    
Fn-Alt-F2 ... genius. Thank you. –  Bill Mote Aug 28 '13 at 22:06
add comment

Do a

sudo rmmod dell_laptop 

(or your computer company name followed by _ nb)

If this does not throw an error (ERROR: Module dell_wifi does not exist in /proc/modules) press fn+f2 and then do a

sudo modprobe dell_laptop

(or your computer company name followed by _ nb)

And then check if wireless is working.

share|improve this answer
add comment

This solution worked for me:

sudo modprobe -r dell_laptop

Once I entered that, my physical switch could turn on/off the wireless.

(reference)

share|improve this answer
add comment

I had a problem with the Wifi/Bluetooth switch - It didn't recognized it as turned on any more. What I did was went in BIOS and set it to always on (disabled the switch). Maybe you have that option too, even if you said you don't have a switch. (Inspiron 1525)

share|improve this answer
add comment

Run these commands:

sudo rmmod -f dell-laptop
sudo rfkill unblock all
share|improve this answer
add comment

Just press Ctrl+Alt+T on your keyboard to open Terminal. When it opens, run the command below.

sudo rfkill unblock all 

It works for me. I have a Sony Vaio VPCEG.

share|improve this answer
add comment

dell inspirion...remove and replace battery...then default the bios..but then dont touch the wireless tab or youll have to do it all over again. this worked for me

share|improve this answer
    
I'll try this at home... Do I do this in the BIOS settings? –  lowerkey Jul 12 '12 at 8:30
add comment

I had a similar problem some months ago with my Dell 1545.

At Boot press F2 to get into set up and check the Wireless settings.

share|improve this answer
add comment

I use Xubuntu 12.04 on a Dell Inspiron Mini.

I could solve the problem of my wireless being disabled by hardware switch by re-setting the boot options in the boot menu to default settings. After that the hardware switch for the WiFi was turned on again.

(Unfortunately, the proposals with rfkill and rmmod did not work for me. Neither did it help me to remove the battery.)

share|improve this answer
add comment

Maybe you have activated airplane mode. Goto system settings -> network -> disable airplane mode on top right corner.

share|improve this answer
add comment

protected by Community Jun 16 '13 at 0:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.