Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm trying to rip an audio cd from my old library but when I try (with every app) to do that, the process is too slow. For 2 tracks it need more than 2 hour and then it crash!

I tried to make:

$ sudo hdparm -d1 /dev/sr0

but the response is

$ /dev/s$ /dev/sr0:

setting using_dma to 1 (on)

HDIO_SET_DMA failed: Inappropriate ioctl for device

HDIO_GET_DMA failed: Inappropriate ioctl for device r0:

setting using_dma to 1 (on)

HDIO_SET_DMA failed: Inappropriate ioctl for device

HDIO_GET_DMA failed: Inappropriate ioctl for device
share|improve this question
    
I am having a similar issue. Ripping a CD takes 10 minutes per track even though my laptop has mad specs. –  dotdawtdaught Oct 11 '12 at 8:00
    
Did you ever find a solution to this? –  slacy Oct 16 '12 at 4:09
add comment

2 Answers

Instead of using /dev/sr0, use the correct entry from /dev/disk/by-id

For example, I run abcde with the option CDROM=/dev/disk/by-id/ata-PIONEER_DVD-RW_DVR-106D_CJDC269789WL and it now rips at full speed.

share|improve this answer
add comment

I think the correct way to do it is

setcd -x <speed> <device>

See the manpage for details on how speed is expressed. Or rip using this little script,

nenRip I made and configure CDROM_SPEED in there.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.