Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I am new linux user, I dont anything about how linux works, i am working on that, but mean while, i installed ubuntu on my Dell xps 15z, it works fine, except for the keyboard and the touch pad mouse. I searched for the solution but no success, please anyone have solution for this, I am very excited about linux, it very beautiful, very user friendly, I want to replace my windows with it.

Ps. Please be specific in your answer 'couse i dont know anything about linux, keep in my I am a very new user.

share|improve this question

5 Answers 5

I have a XPS 15z too and I will tell you what I did on my xps. First, about the keyboard i don't know what happend with yours, on my notebook it works very well, i think that you will have to reinstall ubuntu to fix this. But for the touchpad has a simple solution, you will open the terminal (ctrl+alt+T), type sudo gedit /etc/rc.local and edit the file wich opened. Before the line exit 0 you will add the following lines:

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

Save the file and reboot the computer, i believe after this the touchpad will work. Another thing is about the videocard, it not works in ubuntu, i try so many solutions but anyone works.

I hope i could help you, sorry about my "english', its not my native language.

share|improve this answer
    
Thanks for the quick answer, I tried this but no luck, may be it is a problem with my installation, I will try reinstallation, hope it orks this time. –  hemn a Apr 30 '12 at 19:55
    
I just reinstalled Ubuntu, and applied your commands, now it is not working, but when I close the laptops lid and open it after a while, the touch pad and the keyboard will work, I don't know what is the problem, but right now it is better than nothing, if you know how to fix this i will appreciate it, Thanks again. –  hemn a May 1 '12 at 4:09

I've got DELL XPS 15z too, and I just installed ubuntu 12.04.

About videocard, I install Bumblebee with this commands :

sudo add-apt-repository ppa:bumblebee/stable

Then, I reloaded with :

sudo apt-get update && sudo apt-get upgrade

Just to be sure the system was up to date, and I installed :

sudo apt-get install bumblebee bumblebee-nvidia

One more thing to do :

sudo usermod -a -G bumblebee $USER

Where $USER is your username. This is to allow you to choose the videocard later. Now restart your laptop, and enjoy ! To test it, that's very simple : try this to command lines :

glxspheres
optirun glxspheres

And see ! for me in the first case I have 1 to 2 fps, and in the second case I have more than 150 fps. So if you need to use the nvidia card, just add "optirun" at the beginnin of your software launcher.

share|improve this answer

About keyboard and touchpad, I had the same problem you have, I mean : keyboard was working on grub loading page, but not after, on the login shell, and the touchpad was not working too. It take 5 minutes to do it.

I solve the problem by adding acpi=noirq at the end of the boot line.

The way I did the modifications was this :

1/ During the first boot, I press [e] when I was on the grub loading page, then I gone to the begin of the last line and I came back by the left arrow. Then I just added there :

acpi=noirq

But take care, maybe you have qwerty keyboard instead of azerty one (like me) so press [q] instead of [a]...

Then, press [ctrl]+[x] to execute this command line.

2/ Now you should be able to log in.

3/ To keep this modification once for all, you should edit the grub command. Execute this in a terminal :

sudo gedit /etc/default/grub

And modify the line :

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"

It to obtain this line :

GRUB_CMDLINE_LINUX_DEFAULT="acpi=noirq quiet splash"

Then, save, close, and back in the terminal, execute :

sudo update-grub

Now restart your computer, and all should be great... See above my post for the videocard... Enjoy !

share|improve this answer

When i was using ubuntu 11.10 i did almost like this you did. Now on 12.04 i didin't do anything yet, i'm still look for something wich make my HDMI works, did your HDMI work? When i using 11.10 i found the solution on post #118 of this link http://ubuntuforums.org/showthread.php?t=1776254&page=12 an then i turned off my videocard, as it did not work, at least the autonomy of my battery increased double.

Thanks man

share|improve this answer
    
HDMI is not working for me as well, but actually I do not need that, but you can use an adapter for the mini-HDMI to HDMI, it will be working that way, I did not try this but I so it some where, I do not remember. –  hemn a May 10 '12 at 5:34

May this help you, open your terminal and type:

sudo gedit /etc/default/grub

updating the GRUB_CMDLINE_LINUX_DEFAULT line to:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.reset i8042.nomux"

Don't forget to save and close, go back in the terminal run sudo update-grub

Source

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.