Ask Ubuntu is a question and answer site for Ubuntu users and developers. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have a question about ubuntu working on my laptop.

After I installed ubuntu 11.10 on my laptop I noticed that my laptop battery life time reduced to 2.5h when it is full, while its life time in windows is about 4.5h. also I noticed my laptop fan works hardly when my laptop is ON and is on its easy mode(no program is run). In this time my laptop body becomes so hot.I afraid of working with ubuntu on my laptop. does ubuntu have any problem with my laptop? I should add, non of this problems hapened when I'm working with windows.I love working with ubuntu. if there is a solution please help me.

  • my laptop is 'ASUS U45J'
  • cpu: i5-450M
  • VGA nVIDIA GeForce 310M; VRAM: 1GB
  • my laptop is 64bit and I downloaded ubuntu 11.10 64bit
share|improve this question

This laptop is Nvidia optimus enabled. Unfortunately Nvidia doesn't support it on linux. So you need to install bumblebee. This will enable you to turn off your Nvidia GPU to save battery and use only when required.

Installation Instruction

  1. Type the following in terminal,

    sudo add-apt-repository ppa:bumblebee/stable then sudo apt-get update

  2. To install Bumblebee using the proprietary nvidia driver:

    sudo apt-get install bumblebee bumblebee-nvidia

  3. (change $USER to your username) in following commmand

    sudo usermod -a -G bumblebee $USER

  4. Reboot.

If you just want to disable nvidia card, no need to learn followings

Usage Instruction :

To run a program with nvidia card, use optirun command prefixed in terminal. Like to run glxspheres with nvidia card type

optirun glxspheres

To run firefox type : optirun firefox &

Note: If you intend to run 32-bit programs like Wine and using Ubuntu 11.10 Oneiric or later, install 32-bit libraries with: sudo apt-get install virtualgl-libs:i386 libgl1-mesa-glx:i386 libc6:i386

share|improve this answer
thanks for your answer but it doesn't worked. it cant locate package's error is:\ – hojjat Apr 29 '12 at 18:14
sorry, missed a step. Updated now. – Web-E Apr 29 '12 at 18:16

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.