Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded to 12.04 LTS. My Compaq Presario CQ-40 324la touchpad worked after first restarting after installation. But after restarting a second time, the touchpad is completely disabled, without having changed anything in the system.

I've tried solutions but haven't had good results. The applications I've installed (fro "solutions" are:

  • Pointing Devices
  • Synaptiks
  • Dconf-Tools

I've also tried updating GRUB, adding this line:

GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux")

I tried these commands in a terminal. Neither has worked.

sudo modprobe -r psmouse
sudo modprobe psmouse proto=imps

El Touchpad ALPS se desactiva al reiniciar

Recién he actualizado a Ubuntu 12.04LTS y a mi parecer ha mejorado mucho con respecto a 11.10... Pero ese no es mi punto ahora.

El Touchpad funcionó correctamente luego del primer reinicio después de la instalación. Pero luego de volver a reiniciar, el Touchpad queda totalmente deshabilitado sin haber hecho cambio alguno en el sistema.

He probado las soluciones en su mayoría y no he tenido buenos resultados. Las aplicaciones que he instalado (de las "soluciones") son:

-Dispositivos apuntadores. -Synaptiks -DConf-Tools

Y he intentado también actualizando el grub (añadiéndole una linea así: GRUB_CMDLINE_LINUX_DEFAULT="quiet splash i8042.nomux")

Intenté en la terminal con el comando:

sudo modprobe -r psmouse

sudo modprobe psmouse proto=imps

Ninguno me ha resultado bien.

La laptop es Compaq Presario CQ-40 324la

share|improve this question

3 Answers 3

enter image description here

I sometimes face similar problem. Generally running the Synaptiks application once or twice fixes my problem. You can open the dashboard by pressing the Super key and then search for application and select it using arrow keys and run it by hitting enter.

share|improve this answer

I had somewhat the same problem. My touchpad is an Alps multitouch ( Acer Aspire 7741G ). Sometimes, either after removing usb mouse or after resuming from suspend (can't figure out exactly which one, but I think one of these 2), my touchpad would stop working. I tried most advices (psmouse, xinput, etc), none worked. Logging out would make the touchpad work, but only for the login screen, after logging in, it would stop again. Reboot did not help either, same as log out.

while contemplating reinstalling ubuntu, I tried logging in with the guest account. The mouse worked after login! So I started wondering if somehow my account settings (kept in the .xxx dirs/files in your home dir - you can see them with "ls -a" command, like ".config") were at fault. So i did a backup of all my hidden dirs/files, and deleted them all (at login, if they are missing, they will be recreated, and you will have the desktop you had after installing).

And it worked! I didn't figure out exactly where the wrong settings were, but I suspect that it is someting like ".config/unity". If you don't want to lose all your settings (browser, transmission, unity, etc), you can try making a backup and deleting sequentially until you find the source, after that restore the ones that had nothing to do with the problem. I had no patience and deleted them all and had to redo all settings (too lazy to copy from backup).

Hope this helps somebody!

share|improve this answer

I am using Ubuntu 12.04 on Acer Aspire S3-391. It has been working fine. A few days ago after update touchpad syoped working. I checked dconf-tools seetings for mouse it was fine and nothhing else helped. Then I installed xserver-xorg-input-synaptics and after the reboot it strted working.

thanks with regards Vig

share|improve this answer
1  
This is not really an answer. More of an anecdote. Please don't add comments as answers. Invest some time in the site and you will gain sufficient privileges to upvote answers you like, or to add actual comments when seeking clarification of any issues. –  Kevin Bowen Mar 2 '13 at 10:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.