Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I recently upgraded from 11-10 to 12.04 as a dual boot (Windows 7) and am having problems with shutting down. I installed from a CD that I burned from the iso file, and to get it to boot from the CD, I needed to install the special help program from Windows that would then recognize the CD as the system booted.The installation gave me my own user account as well as a guest account.

For the User account there is no "gear" icon (in the upper RH side) from which to access the shut down menu. Interestingly the icons for the Home folder, the Ubuntu One folder, and the System Settings folder are missing, although there are blank places shows these names if the mouse cursor is positioned over these areas. They will even launch with the press of a key - but no icons are visible.

For the Guest account, all of these icons are visible and usable.

The problem that occurs in shutting down is that I need to leave the User account, move to the Guest account (so that I can access the top right "gear" icon that has the shut down menu item) and press the shut down button. The problem here is that when the shut own menu appears and I press the confirmation that I wish to shut down the computer, the page blanks (as one might hope in the process of closing down), and then pops up with the log in menu, giving the option of logging in as a User or as a Guest.

So the questions are:

1) how do you reinstate the far right top icon from which you can access the shut down drop down menu in the User account page.

2) how do you get the icons to display properly on the Left hand side (Home, Ubuntu One, System Settings, and Workspace Switcher)

3) how do you get the system to turn of when you press the shut down button!

Boy oh boy!

Thanks a bunch for any help!

share|improve this question

4 Answers 4

The Problem is MyUnity, I had the same problem, The graphics controller on my Pc is on board and not very good, therefore Myunity caused problems, after removing it and going into appearance and choosing radiance, then setting it back to ambiance, then rebooting the System , everything is back to normal.

share|improve this answer

Reset your unity. :)

  • Press Alt + ctrl + F1
  • Login using your username and password
  • Reset unity , by executing unity --reset
  • Reset launcher icons by executing unity --reset-icons
  • Press Alt + ctrl + F7 to get back to login screen. However I recommend a restart by executing sudo shutdown -r. Let us know if it worked.

  • Reboot once by running sudo shutdown -h now in terminal. Next time it should shutdown normally from User account

share|improve this answer

I have the exact same problem. The solution did not work for me. After unity --reset hundreds of errors and warnings came. The system then seemed to hang. After waiting 5 minutes I gave up.

I found a solution:

  • Using the Software Centre, remove myunity.

  • Start System Settings.

  • From the Personal category, choose Appearance.

  • Change Theme to Radiance (Ambiance was the theme before)

share|improve this answer

I had changed System settings>appearance' => Ambiance to Radiance and lost the gear wheel. I changed it back to Ambiance(default value) and the gear wheel promptly reappeared!
I always blame myself for problems (and I am usually right)!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.