Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have nvidia drivers and dual monitors.

nvidia drivers It worked fine in 11.10 but since todays updates, my unity "launcher" is only on right monitor.

launcher on the middle

On vanila ubuntu display settings it recognizes only one monitor. And it looks like this: ubuntu configuration

So, the questions might be:

  1. Why Ubuntu's "Displays" shows only one monitor where nvidia drivers shows two? I assume nvidia overwrites?
  2. After Lot of playing between these two settings, I can't manage to move menu launcher to left screen. Any suggestions?
share|improve this question

closed as too localized by Tom Brossman, John S Gruber, Mitch, con-f-use, hbdgaf Sep 9 '12 at 13:07

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
Should be closed as too localized, scroll down for OP's accepted answer. –  Tom Brossman Sep 8 '12 at 9:37
    
@TomBrossman The answer is reported not to be working by several people. –  gertvdijk Jan 17 '13 at 14:14
1  
@gertvdijk Hmm, strange. It is still clearly too localized and should remain closed. If this is a bug and is affecting others still, it should be reported on Launchpad and not re-asked here. –  Tom Brossman Jan 17 '13 at 16:51
1  
@TomBrossman Yup. Agree. (didn't say I disagree ;)) –  gertvdijk Jan 17 '13 at 16:56
add comment

6 Answers 6

Maybe it's a bug. Have you tried the Ubuntu2d setting on the Ubuntu button at login?

share|improve this answer
    
I assume you meant Unity 2D. Unity 2D will probably work, but I really want Unity 3D. I prefer gnome shell instead of Unity 2D –  confiq Apr 29 '12 at 17:53
add comment

As a workaround, you could try physically plugging the monitors into the opposite ports on your video card.

share|improve this answer
    
I even tried that... didn't work! :) –  confiq May 2 '12 at 18:44
add comment

I had the same issue and what solved it for me was first selecting the left screen in the 'X Server Display Configuration' and setting the position to 'Right of'.

This resulted in the launcher at the correct position on the virtual desktop but with my displays physically swapped, so I simply physically plugged the monitors in the opposite ports of my video card.

I guess the bug is that the launcher is always displayed on the monitor that is physically plugged in in the first port of the video card, ignoring the position you configured in the Nvidia tool.

I hope this works for you.

share|improve this answer
add comment

I'm facing the same bug (I think it is).

OS: Ubuntu 12.04 Graphic Card: GeForce 310M

On dual monitor configuration the unity launcher is on right (wrong) screen.

I tentatively solve this by setting the primary monitor's position to Right of and then setting it back to Absolute. I do this on every reboot (!).

Furthermore I set this via gconf-editor:

/apps/compiz-1/plugins/unityshell/screen0/options/num_launchers=1

This forces the launcher to appear in only one monitor (otherwise for me it appears on both)

Naver had problems with Ubuntu 11.04

Hope this helps.

Edit: Actually I use to set both monitor to Absolute with the right one positioned from the pixel width of the left one.

So, in my case:

1366x768  Absolute +0+0 Primary
1280x1024 Absolute +1366+0
share|improve this answer
    
Do you still have this bug? In my machine it's fixed –  confiq May 13 '12 at 6:56
add comment

I think it's because of your configuration. If you select "twinView" in nvidia-settings, for gnome displays tool it's like there's just one gigantic display. Try the "separate x screens" option in nvidia-settings.

share|improve this answer
    
That creates totally distinct displays. You can't even drag windows between them. –  Timmmm Jul 14 '12 at 15:55
add comment
up vote 0 down vote accepted

It appears this was a bug in Unity. I've update last week and tried again, problem is fixed.

Thanks for all answers!


Edit: After reading few comments, It seems I just got lucky, people still have same problem that I had. Interesting thing is that I've changed computer and graphic card since I asked the question and it's still fixed for me :(

share|improve this answer
1  
What means "fixed"? Does it now recognize the Twinview configuration? Because for me it still doesn't, so I now get a launcher on both screens, which I find much more annoying. –  kynan Jun 29 '12 at 13:43
1  
Didn't work for me too... –  Anthony O. Jul 23 '12 at 8:54
1  
Just to say that at 15 Out 2012 hasn't been fixed, by any update at all. You probably just got lucky and the unity launcher got placed on the right screen. However It mostly doesn't, and in order to get it in the right place you have to toy arround with the position and resolution of your monitors, and by some change you might get it right. However far as Ubuntu 12.04 updates go nothing to "fix" this as you say sorry. –  Fábio Antunes Oct 15 '12 at 0:10
    
@FábioAntunes: I edited my answer. –  confiq Jan 17 '13 at 14:12
    
The reason Unity doesn't place the launcher in the right place is because both monitors are being recognized as one (Unity or X.Org problem maybe), like it shows in the image presented with this question. However far as I know this isn't a localized bug, because in 4 different monitors I have here to test with, they are all recognized as a single monitor in under 3 different installations of Ubuntu 12.04 LTS. (continuing...) –  Fábio Antunes Jan 20 '13 at 16:17
show 1 more comment

Not the answer you're looking for? Browse other questions tagged or ask your own question.