Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading to version 12.04 LTS I experience some problems with my touchpad. Everytime I tap on the touch the cursor is moving around (for example if I want to close a window, I click on "x" button from touchpad, the cursor is moving and not always hit the "x" button). Touchpad left click, right click is working well, but tap... Did u guys experience the same problem? Is there something related to sensitivity? how to fix it?

Thanks

EDIT: Need help !!! It is really annoying

share|improve this question

4 Answers 4

It seem to be just a synaptics driver configuration, I solved by adjusting the FingerLow and FingerHigh values with sinclient. See your current configuration with synclient, here is my console output

$ synclient | grep FingerHigh
    FingerHigh               = 30
$ synclient | grep FingerHigh
    FingerLow               = 25

I change the FingerLow value to 35, and FingerHigh value tu 40 and it works better! Try:

$ synclient FingerHigh=40
$ synclient FingerLow=35

The values were determined experimentally. To make the configuration permanent I created the file /etc/X11/xorg.conf with the following content

Section "InputClass"
    Identifier "touchpad"
    Driver "synaptics"
    MatchIsTouchpad "on"
    Option "FingerHigh" "40"
    Option "FingerLow" "35"
EndSection

Regards!

share|improve this answer
    
I made it with 40 and 35 and it's working much better. Thanks for info. –  Dave Jun 17 '13 at 16:01
    
Same for me, actually. –  Carlos Jun 18 '13 at 2:50

Same problem here with my Tecra R840 with Alps touchpad. It's definitely a regression in 12.04. It can slightly be diminished by changing the values of HorizHysteresis and VertHysteresis via synclient (see synaptics manpage). But the problem still exists.

And yes, it really is very annoying and the reason why I don't use this machine with Ubuntu.

share|improve this answer

You may want to try entering "synclient" in the terminal to see what your FingerHigh & FingerLow values are. In my case, the movement was occurring with taps being recognized as released too early. You can see explanations of the different synclient values here: http://manpages.ubuntu.com/manpages/lucid/man4/synaptics.4.html Note that FingerLow can't be set higher than FingerHigh, so both will have to be changed as you adjust FingerLow. I used FingerLow=55 & FingerHigh=60, which eliminated the issue for me. If this fixes the malfunction, you will need to create an executable script to run at startup and resume, because the changed settings do not persist due to a bug (which supposedly has been reported on Launchpad). I'm still working on making scripts to run at the right time, if anyone has input. Hope this helps!

share|improve this answer

I had a similar problem on my Toshiba Satellite and followed the above instructions. However, 35-40 didn't help and 55-60 was too much and the touch pad wasn't responsive at all. I figured out the following works best for me.

FingerLow               = 45
FingerHigh              = 50
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.