Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just upgraded my system and did a clean install of Ubuntu when I did (Installed Oneiric Ocelot from the CD last week but yesterday upgraded to 12.04 LTS). I have an i7 920 (quad core with hyperthreading), so I should be seeing 8 processors, but I only see one in the System Monitor graph.

cat /proc/cpuinfo returns:

processor   : 0
vendor_id   : GenuineIntel
cpu family  : 6
model       : 26
model name  : Intel(R) Core(TM) i7 CPU         920  @ 2.67GHz
stepping    : 4
microcode   : 0x10
cpu MHz     : 2672.633
cache size  : 8192 KB
physical id : 0
siblings    : 1
core id     : 0
cpu cores   : 1
apicid      : 0
initial apicid  : 0
fpu     : yes
fpu_exception   : yes
cpuid level : 11
wp      : yes
flags       : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe syscall nx rdtscp lm constant_tsc up arch_perfmon pebs bts rep_good nopl xtopology nonstop_tsc aperfmperf pni dtes64 monitor ds_cpl vmx est tm2 ssse3 cx16 xtpr pdcm sse4_1 sse4_2 popcnt lahf_lm ida dts tpr_shadow vnmi flexpriority ept vpid
bogomips    : 5345.26
clflush size    : 64
cache_alignment : 64
address sizes   : 36 bits physical, 48 bits virtual
power management:

From my recollection of previous installs with SMP working, there should be multiple entries in /proc/cpuinfo--one per processor. I see only one.

My first thought was that a non-SMP kernel was installed. However, uname -a returns:

Linux compname 3.2.0-24-generic #37-Ubuntu SMP Wed Apr 25 08:43:22 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

So am I using all available cores or not? And if not, what is causing it given that I appear to be running an SMP kernel?

Thanks!

share|improve this question
    
If /proc/cpuinfo says you have one core, Linux is only using one core. I'm puzzled as to why. –  Gilles Apr 29 '12 at 14:57
    
@Rinzwind That's a great suggestion. I turned them off the other day because my suspend was going wonky, but I'll turn them back on as soon as I get to a point where I can reboot and let you know how it went. –  Ari B. Friedman Apr 29 '12 at 15:07
    
Nice question bro! –  gajdipajti Apr 29 '12 at 19:30

1 Answer 1

up vote 3 down vote accepted

Enable ACPI features in your BIOS. If you turn this off your system will use 1 cpu.

share|improve this answer
    
That did it! Thanks. –  Ari B. Friedman Apr 29 '12 at 15:26
    
And oh, my is it faster ;-) –  Ari B. Friedman Apr 29 '12 at 15:32

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.