Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a computer dedicated to media playback which I just updated to version 12.04.

Since the upgrade, I just can't seem to get the screen saver to stop coming on while watching just about any kind of video.

I have of course opened System Settings -> Screensaver to try and turn it off. Whenever I do, I get this error message:

enter image description here

It doesn't seem to matter if I press "Cancel" or "OK". Either way, I get to the Screensaver interface settings where I put "Mode:" into "Disable Screen Saver". And yet, the screen turns black about 15 to 20 minutes into any video.

I looked for solutions on the web. I've tried this at the command line:

xset -dpms && xset s noblank && xset s off

Lastly, I found some suggestions for editing the /etc/X11/xorg.conf file. However, mine is completely blank, and it seems that if I put anything at all in there, it causes the X server to fail completely on boot.

How do I get my screensaver to be off and to stay off?

share|improve this question

1 Answer 1

up vote 3 down vote accepted
+50

A few things you try

  1. Verify you don't have gnome-screensaver installed

    apt-get remove gnome-screensaver

  2. You could remove xscreensaver

    apt-get remove xscreensaver

You can also check in

/home/USER/.xsession-errors

and see if there is anything indicating why it may be broken (it's dying when trying to start).

A quick search shows an older post from 2009 with a similar issue. I've copied the relevant section of the same file from my Mythbuntu 12.04 machine below. You may want to check the same section in your file.

From /etc/xdg/xfce4/xinitrc

# launch a screensaver if enabled.  do not launch if we're root or if
# we're in a VNC session.
screensaver_enabled=`xfconf-query -c xfce4-session -p /startup/screensaver/enabled 2> /dev/null`
if test $UID -gt 0 -a -z "$VNCSESSION" -a "$screensaver_enabled" != "false"; then
    screensaver_type=`xfconf-query -c xfce4-session -p /startup/screensaver/type 2> /dev/null`

    case "$screensaver_type" in
        xscreensaver)
            xscreensaver -no-splash &
            ;;

        gnome-screensaver)
            gnome-screensaver &
            ;;

        *)
            if test x"`which xscreensaver 2>/dev/null`" != x""; then
                xscreensaver -no-splash &
            elif test x"`which gnome-screensaver 2>/dev/null`" != x""; then
                gnome-screensaver &
            fi
            ;;
    esac
fi
share|improve this answer
    
apt-get remove xscreensaver seems to have finally done the trick. –  Dave M G May 4 '12 at 4:17
    
@dave I find it odd that removing xscreensaver package helped, since xscreensaver works only, if the daemon is running. –  jarno Jan 5 at 20:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.