Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

My LaserJet P1005 used to work fine after installing hplip in 11.10. Now it is not recognized when plugged in. No pop-up, nothing. Any ideas?

share|improve this question
1  
Solved it. After installing hplip, all I had to do was run ’sudo hp-setup’ after connecting the printer. Tried it a few times without "sudo" and plugin install failed. –  arno Apr 29 '12 at 16:23
    
When I do that and select "Download" it just sits there thinking and never does anything. –  Frank Barcenas May 11 '12 at 15:34

1 Answer 1

Download and install HPLIP directly from the HP OPEN SOURCE website. http://hplipopensource.com/hplip-web/downloads.html

Click on DOWNLOAD HPLIP. Find the downloaded file and right click on it and select PERMISSIONS. Select MAKE EXECUTABLE. Click OK.

Right click on the file again and select OPEN then EXECUTE. Follow the instuctions.

*Reason it works is mainly because it detects and installs dependencies that the apt-get or software center version won't.

share|improve this answer
    
An alternative way to do this: After installing hplip, connect the printer, then use sudo hp-setup at the command line. –  Abdolkarim Behravan Jun 20 at 19:02

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.