Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I updated to Ubuntu 12.04 with Compiz..now Compiz is failing and I have no tool bars or ways of getting to applications except for firefox from a link presented from sending an error report. How am I supposed to:

  1. Fix this mess with no navigation to get to the terminal, or software center.
  2. When will this problem be fixed?
  3. When I updated the system why didn't it change me back to the crappy Unity interface (No offense).
  4. If it can't be fixed how do I get my files back?
share|improve this question
add comment

3 Answers 3

  1. You can goto terminal if no gui is working using shortcut Alt + ctrl + T.

  2. To solve the problem, Reset unity and compiz settings. Every settings of compiz will be resetted.

    • Press Alt + ctrl + F1
    • Login using your username and password
    • Reset compiz by executing gconftool-2 --recursive-unset /apps/compiz-1
    • Reset unity , by executing unity --reset
    • Optionally you can reset launcher icons by executing unity --reset-icons
    • Press Alt + ctrl + F7 to get back to login screen. However I recommend a restart by executing sudo reboot. Let us know if it worked.
  3. When you updated the system, possibly your changes in previous version made some conflicting changes with the update.

  4. You can go to terminal as stated in step 1, and then run nautilus to open the file browser to get your files back.
share|improve this answer
add comment

I tried all of the different "fixes". The only one that worked for me was as follows.

sudo apt-get install nvidia-current

After that and a reboot all GUI was there.

share|improve this answer
1  
Welcome to Ask Ubuntu! Please note that it's advisable to run sudo apt-get update before installing or updating software from the command-line. sudo apt-get update fetches updated information about what packages are available in what versions from where. –  Eliah Kagan Jul 14 '12 at 14:01
add comment

In my case the shortcuts were not working. I couldn't even start terminal.

I found the solution here: https://answers.launchpad.net/ubuntu/+question/194996

On fresh install, Ubuntu 12.04 ran Compiz alright. I ran the Update Manager, rebooted and Compiz was good. After installing Additional Drivers, i.e. Nvidia, Compiz crashed and nothing but wallpaper appears. Right-click on screen works and I clicked on Change Desktop Background, then All Settings. I went to Additional Drivers and uninstalled Nvidia. Rebooted and all is well again. Seems like a bug.

share|improve this answer
    
I had this exact problem and tried everything here. Dumitru's solution worked except that I did not have to uninstall the driver. Switching from "version current" to "version current-updates" and then rebooting worked. –  user86848 Sep 1 '12 at 2:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.