Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

Everytime I shut my computer down or reboot it there is a very loud pop/crack from the speakers. It sounds dangerous, like they are going to blow up. Is there a way to automatically mute the volume on shutdown?

share|improve this question
add comment

5 Answers

The popping is not a result of your computer not being muted; it's probably a result of capacitor discharge being sent to your speakers.

From what you've said, it sounds like you have a set of external speakers? If this is the case, turn them off before booting down; this will prevent any discharge from being amplified, and therefore being heard.

share|improve this answer
    
In my case, clicking doesn't occur when shutting down Windows, only when shutting down Ubuntu. Of course, the cause of the click is physical - capacitor or spark, but the pre-cause is possible the disgraceful shutting down of the sound card. –  mbaitoff Apr 29 '12 at 13:54
add comment

Open terminal and do:

Code: gksudo gedit /usr/lib/pm-utils/power.d/intel-audio-powersave Find this line:

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

and comment it out by putting a "#" in front of it like this:

# INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

Just below this line you make a new line, like this:

INTEL_AUDIO_POWERSAVE=false

So now you will have:

# INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}
INTEL_AUDIO_POWERSAVE=false

Save the file (File > Save) and exit.

Reboot the computer.

The popping sound will be gone.

NOTE: If you for some reason need to undo the setting, just open the file again and remove the "#" from:

INTEL_AUDIO_POWERSAVE=${INTEL_AUDIO_POWERSAVE:-true}

and delete this line:

INTEL_AUDIO_POWERSAVE=false

Save the file.

Reboot.

http://gnometechblog.weebly.com/1/post/2012/03/fixing-popping-sound-in-ubuntu.html

share|improve this answer
add comment

That's a known bug: https://bugs.launchpad.net/ubuntu/+bug/373452 Do you have an HP laptop?

share|improve this answer
add comment

ok - forget about changing /usr/......./intel-audio-powersave - that doesn't seem to work with my i5 desktop (13.04 64 bit - doesn't matter whether you start with lightdm or gdm so it must be ubuntu problem. can't believe a "mainstream" OS like this has has this problem circulating since ubuntu 9 (or earlier) - do they not make each release better than the previous or do the developers get kudos for fixing bugs a second, third, fourth and fifth time (ringtail) - maybe they could get started on fixing it for 13.10 so that it doesn't reappear (again) when i upgrade.

share|improve this answer
add comment

You need turn EAPD off in alsa driver.

http://www.alsa-project.org/main/index.php/Detailed_HDA_changes_v1.0.24_v1.0.25#HDA_Intel_driver

share|improve this answer
    
Welcome to Ask Ubuntu! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. –  fossfreedom May 5 '13 at 8:24
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.