Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I'm new to Ubuntu, 11.10 was the first version of Ubuntu I used, it was very good.

I've just made a new install of 12.04 (clean install, not upgrade), it's also very good too but the auto-hide function of launcher is really annoying, it doesn't show up when I move the mouse (or even click many times) to its area on the left. Does anyone else experience this problem? Is there a way to overcome this? Thank you.

share|improve this question
    
Welcome to Ask Ubuntu! This question should instead be filed as a bug report, thanks! Instructions here. –  Jorge Castro Apr 27 '12 at 4:16
    
Try resetting your unity configuration before reporting a bug: askubuntu.com/questions/17610/… –  Jorge Castro Apr 27 '12 at 4:16
1  
Yes, I also have this problem. You should [report it as a bug ](askubuntu.com/questions/5121/how-do-i-report-a-bug) –  Marius Balaban Apr 29 '12 at 11:46
2  
Cannot make autohide work at all on Virtual Box installation with guest additions. –  Roman D. Boiko May 4 '12 at 6:44
1  
@MariusBalaban: Here you can find a bug report already. –  Jakob May 4 '12 at 7:31
show 2 more comments

closed as off topic by Jorge Castro, hexafraction, Eliah Kagan, jokerdino, Mitch Oct 1 '12 at 12:00

Questions on Ask Ubuntu are expected to relate to Ubuntu within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

11 Answers

1) It is NOT about how hard you push the mouse cursor to the screen edge, but how far you push it. To be able to reveal the launcher, you must continuously push the cursor against the edge to reveal it.

2) To fix the launcher reveal sensitivity:

a. Install then start "CompizConfig Settings Manager"

b. Navigate to "Desktop" -> "Ubuntu Unity Plugin" -> "Experimental" tab

c. Find the string "Launcher Reveal Pressure"

d. The default is 20, change it to 8 (or whatever you prefer)

e. You don't have to close CCSM to apply the changes. Keep changing the value till you are satisfied with the result, then close CCSM.

share|improve this answer
add comment

For me it work very well. You have to "push" the mouse arrow to the left side of the screen to show the launcher. And you can set up the sensitivity how hard you have to push. That's a really nice solution, because it was always annoying that the launcher shows up when you just scratch the left border of the screen. Especially when I try to hit the Back button of Firefox.

You should spin the mouse over the left side (like to go over left border of screen)... and the launcher magically will appear...

share|improve this answer
    
I agree, it feels rubbish for a while but then if you ever have to use 11.10 again you'll realise what am improvement it is. –  Ross Fleming Apr 29 '12 at 12:13
    
It seems like the sensitivity is rather dumb - even though it's presented as a slider, there are really only two apparent modes. Basically, I couldn't tell any difference until I dragged it about halfway across; then, there was no further difference regardless of how far I went. So it's either 'low' or 'high'. –  GalacticCowboy Apr 29 '12 at 18:47
add comment

There appear to be several changes in the autohide feature in 12.04, at least as it works on my desktop system which uses a 1920x1080 monitor in portrait mode. I am using the 3D Unity implementation, with a low end ATI graphics card.

1) In a fresh install, autohide is turned off. New Ubuntu users will probably not even realise that the autohide function exists, unless they are shown by someone, or stumble across the setting in the Appearance panel.

2) With autohide on, when no programs are running, the launcher is hidden. This is a change from previous versions, which showed the launcher when nothing was running.

3) My experience about how autohide works seems to be different than that of a couple of other posters. On my system, autohide is responsive not to how far you move the cursor, but to how fast the cursor is moving when it is beyond the left edge of the screen. A slow long movement a long way past the screen edge creates a gray flicker at the screen edge as if the launcher is just on the verge of showing itself. It takes rapid movement to make the launcher show. In practice, I need to jerk or snap the cursor past the left edge of the screen to reveal the launcher.

4) The range of sensitivity available for autohide isn't big enough. Even turned up to high, I have trouble generating enough cursor velocity to get the launcher to activate.

share|improve this answer
add comment

Is your Launcher configured to auto-hide? Because in Ubuntu 12.04LTS, that behaviour has changed slightly. You now have to press the pointer "out of the screen" in order to display it. That is; if you move your pointer against the Launcher, you'll see a shadow appear along its edge. If you continue pressing it, then the shadow grows and the launcher appears.

It is designed this way in order to minimize the number of times it appears when you really wanted to use the back-button in Firefox, or something like that. The behaviour is configurable, and you can choose how sensitive the launcher should be in System Settings > Appearance > Behaviour.

share|improve this answer
add comment

It's working fine. In 11.x, the launcher revealed on touching the left display border for a length of time. In 12.04 this behavior is changed; the launcher reveals when you "push" the mouse against the left-most edge for a certain mouse distance. Unity designers changed this because the old method lead to annoying accidental launcher reveals, for example when reaching for the browser back button. The "shadow" your seeing indicates how far you've pushed against the display border.

The launcher's sensitivity (that is, how far you need to push) can be configured at System Settings > Appearance > Behavior > Reveal sensitivity. At its highest level of sensitivity, the Unity launcher acts functionally identical to its predecessors in 11.x.

share|improve this answer
    
Because of this change I cannot use autohide on Virtual Box installation. I have guest additions installed, so mouse never goes through the border, it stops in Ubuntu 12.04 and further move happens in my host OS. –  Roman D. Boiko May 4 '12 at 6:50
add comment

The likely issue here can be corrected in ccsm. Go to the Desktop section and select Ubuntu Unity Plugin. Make sure Enable Ubuntu Unity Plugin is checked. If you still have trouble with autohide showing up, check out the experimental tab. I fixed this on my system by some of the settings there to the default, although I am uncertain which one fixed it. Reveal pressure seems to be a likely candidate.

share|improve this answer
add comment

I had a little trouble with this using various sensitivity levels but it seems to be related to the speed at which you try to move the cursor out of the screen.

If I casually move over the edge then nothing happens. But if I move out quickly and with purpose then I can get to the panel. Once I realized that it just took 60 seconds of practice to get the knack.

share|improve this answer
add comment

Same problem here. That 'shadow' shows up (to me, it's a bug). But when 'pushing further' as in here suggested, the launcher still doesn't show up. In order to make the launcher appear, I have to do the following:

  1. Shake the mouse pointer around on some random spot on the screen.
  2. Then throwing it against the left screen edge.

Without shaking the mouse pointer randomly around first, the launcher will not show up. Clearly, a bug. And Canonical once more is disappointing and fails in providing most basic things to actually work.

Good-bye. Switching back to Kubuntu (again). This was my 3rd attempt in using Unity since it was released. Each time, it was a collection of bugs. KDE has bugs as well, but at least basic things work, whereas in Unity they don't. Fail.

share|improve this answer
add comment

This worked for me:

  1. Auto-hide launcher "ON"
  2. Sensitivity "High"
  3. After the launcher has hidden, hit the left side of the screen with the pointer, and drag it down against the edge. The launcher will pop up.

Hopefully this will be fixed by the good folks at Ubuntu.

share|improve this answer
add comment

I have a similiar issue with dash auto-hide but a bit different from those presented here.

I have autohide enabled, and dash autohide works well most of the times, but now and then, the autohide stops working, and the dash is always present.

I go to system settings, and confirm that autohide is enabled.

I then disable the autohide, enable it again, and still autohide doesn't work.

Does anyone have the same problem? Is this a known bug?

share|improve this answer
add comment

protected by Community May 8 '12 at 8:57

Thank you for your interest in this question. Because it has attracted low-quality answers, posting an answer now requires 10 reputation on this site.

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.