Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

So I have vsftpd 2.3.5 installed (using apt-get) and I want to install vsftpd-ext.
But I have to compile it my self and install.

How can I install it so that it updates the version installed by apt-get
and I still can run, for example, service vsftpd start

As I did it now the program is just installed "side by side" and not updated the already installed version. (Following this guide: http://www.thegeekstuff.com/2010/11/vsftpd-setup/)

share|improve this question
add comment

1 Answer

up vote 0 down vote accepted

The problem is because you have two conflicting pieces of software installed; 'vsftp' and 'vsftp-ext'.

First you need to remove the version installed by apt-get. Open a terminal and run:

sudo apt-get remove vsftpd

This will remove the version of vsftpd installed by apt-get. Once you've done that, it's probably a good idea to recompile 'vsftpd-ext', just to make sure everything is setup properly. Just follow that guide again, and everything should be fine.

share|improve this answer
    
If I run service vsftpd I get "vsftpd: unrecognized service" –  Patrik Apr 29 '12 at 13:03
    
Try 'service vsftpd-ext' instead. –  jdp407 Apr 29 '12 at 13:47
    
I get the same error: vsftpd-ext: unrecognized service –  Patrik Apr 29 '12 at 14:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.