Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

After upgrading from Oneiric to Ubuntu Precise booting ends up in a black screen with no whatsoever reaction. There is a short flicker showing the login screen before turning black, during which I can get to a login terminal via ctr+alt+f1. Already tried removing xorg.conf, uninstalling compiz, setting grub options to nomodeset or raden.modeset=0 , re-installing Xorg . Nothing would help.

Please help!

Thanks, Alice

share|improve this question

4 Answers 4

What drivers are you using? I have a fresh install of Ubuntu 12.04 with the HD3200, have tried both open source drivers and ATI's drivers with no problems.

What drivers were you using before the upgrade? Have you tried a different display manager yet? Does Ctrl-Alt-F[number] (where [number] is 1 to 6) bring up a terminal? If the terminal appears, I'd runsudo apt-get update && sudo apt-get dist-upgrade if you haven't already.

share|improve this answer
    
Under maverick i had the ubuntu provided fglrx drivers, and tuned screens and graphics via amdcccle. –  Alice May 2 '12 at 14:51
    
I did an upgrade to precise from a working maverick setup. After restart the screen would freeze after a short blink on the login screen to absolutely no reaction. The time window with a chance to get in the terminal would be like 2 secs. I did the update and dist-upgrade but would not solve the problem –  Alice May 2 '12 at 15:13
up vote 0 down vote accepted

Seems to be a problem with the proprietary Drivers a.k.a. Catalyst/fglrx after upgrade.

Reached to a normal functioning login and laptop desktop by the following steps. From command line mode which I could enter via Ctrl+ALT+F1 during the short flick of a purple background screen before everything freezes :

  • enabling restricted repositories, via manually adding to these lines to

/etc/apt/sources.list

deb http://us.archive.ubuntu.com/ubuntu/ precise main restricted

deb-src http://us.archive.ubuntu.com/ubuntu/ precise main restricted

  • (re-)installing Ubuntu-supplied fglrx/Catalyst

sudo apt-get update

sudo apt-get remove --purge fglrx*

sudo apt-get install fglrx fglrx-amdcccle

  • generating a new /etc/X11/xorg.conf file

sudo amdconfig --initial -f

Still, with that basic configuration dual screens would not work and graphics seem to be a bit upset, amd's catalyst center (gksudo amdcccle) keeps on crashing when hitting apply. The latter is a known bug under maverick as well, if there is no X11/xorg.conf file present, however, now catalyst seems to crash always)

share|improve this answer
    
see also [wiki.cchtml.com/index.php/… –  Alice May 2 '12 at 15:36

I see a lot of people having trouble with this, including me.

I 've tried most of the solutions/guides online but none could fix it. As long as I am using the proprietary drivers, I get stuck at the "black screen" during boot.

To "solve" this: 1) Ctrl + Alt + F1 to open the terminal and loggin. 2) Navigate to the configuration file's directory (in my case "cd /etc/X11") 3) delete the ACTIVE configuration file "sudo rm xorg.conf" 4) "sudo reboot"

This will solve your black screen problem for sure. But unfortunately you will be running Ubuntu without the cool graphics. Another approach is to use the open source drivers. They work for me with normal graphics but the performance is somewhat lower than before (meaning before i upgraded to 12.04 from 11.10).

Cheers, Mitch

share|improve this answer

The 3200 isn't supported in the current driver, you'll have to use the legacy one.

You can install it with:

sudo sh ./amd-driver-installer-12.6-legacy-x86.x86_64.run --buildandinstallpkg Ubuntu/precise

It worked for me (until I updated to a 3.4 kernel, so now I'm back on the open-source one).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.