Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I just installed Ubuntu 12.04 and... I've got a problem :) I'm living in Poland, so I want to write texts in polish with polish chars such as ąćęłńóśźż, too. Unfortunately, it's impossible. We write polish chars by pressing AltGr and chosen key (e.g.: AltGr + A = ą, AltGr + X = ź, AltGr + C = ć, etc.), but when I press AltGr, it isn't like pressing AltGr, it's like pressing Alt - I can open menus with their mnemonics, and I can't enter polish chars. I've got, of course keyboard layout set to Polish.

And btw. - in Oneiric there was everything OK...

So my question is: how to fix it?

share|improve this question
    
What keyboard did you choose during install? Also see system settings, keyboard, layout setting. Did you choose a polish layout? –  Rinzwind Apr 29 '12 at 11:54

2 Answers 2

up vote 2 down vote accepted

Open "System Settings" and then "Keyboard Layout". Check that there is a Polish layout in the list of keyboard layouts on the left of the window. If there isn't, click the "+" button at the bottom left and add it.

If you have more than one keyboard layout added, you also need to check that you're currently using the right one. When more than one keyboard layout is added, a keyboard symbol with a two letter country code should appear in the bar at the top of the screen. Click this icon and select the polish layout. The icon in the bar should then show the letters "pl" next to the keyboard symbol.

By adding a polish layout to my settings, I can type ą, ź and ć without a problem.

From the "Keyboard Layout" settings page, you can also check that the selected layout is as you expect. With the polish keyboard layout selected, click the small keyboard icon at the bottom left of the window. This should show you a diagram of your keyboard showing which letter can be typed with which key.

Check that the Polish characters are where you expect them to be and that the AltGr key is labelled something like "Level3 ..."

share|improve this answer
1  
Thank you! Now it works! :) I changed Level3 key in keyboard layout options to AltGr and now it works! Thank you so much :) –  m4tx Apr 29 '12 at 12:42
    
In Ubuntu 14.04 (Gnome Shell, not sure if it matters) i had to go into System Settings -> Keyboard -> Shortcuts -> Writing and set "Key for input of alternative characters" (or how it's named in English) as Right Alt. –  user31389 Jun 29 at 19:02

try super + shift + space or super + space, if you have already installed Polish language pack

share|improve this answer
    
You didn't even explain that this would switch current keyboard layout if there's more than one installed. –  user31389 Jun 29 at 19:03

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.