Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have a "multi-monitor" system on my desktop. My main screen is connected via DVI (a Samsung Sync Master, 1680x1050) and the other screen is a LG Samsung (full hd 1920x1080) that is connected via HDMI. Both are in the same graphics card, a Asus Geforce GTX 550 TOP.

The problem is that I can't use them both as I use on Windows or on my netbook. My netbook (an Asus 1215P) automatic detects all kind of screens under the settings that come with Ubuntu 12.04 (I think in english is called Screens, not sure). On my desktop, those settings only show one screen and call it as a "laptop screen".

I went to x server settings and my TV appeared there. I activated it, and set "separate x screen" (or something like that). I saved the settings and then I rebooted.

My TV screen was all grey and my mouse was a big "X". I couldn't move any window between screens.

I went back to x server settings and activated Xinerama. When I rebooted, multi-monitor was working, I could move windows between screens, and the login screen ever adapted to where my mouse was. But with Xinerama, my Unity 3D became 2D, and Ubuntu keeps giving me "system error" dialogs.

How can I set my multi-monitor system correctly with Unity 3D and no errors?

PS: My Ubuntu is 12.04 64-Bits

share|improve this question
    
I have similar hardware and I can run Xinema in Unity 3D. Try playing with nvidia driver (example saving x.org file) and then restart... –  confiq Apr 29 '12 at 13:34
    
I've tried lots of configurations for x.org, I reseted it, I even formated my computer, it stays the same... –  joelalmeidaptg Apr 29 '12 at 13:44

1 Answer 1

You can't use the default display settings to set-up multi-monitor setup with nvidia cards. Only setting the sticky edges and launcher on both/one screen need to be set in settings.

All I did in 12.04 was:

  • Install the current nvidia drivers (probably already installed). Search nvidia-current

  • Use the nvidia x server settings

  • Setup the multiple monitors in 'twinview' (choose resolution and drag the screens in position you want them)

  • Save conf.

To see changes you only need to log out/in.

If you click apply it tries to do it without logging out.

I had these problems in 11.10. Found in my favorites: 11.10 dual monitor nvidia card problem

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.