Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

I am new to Ubuntu and really would like to replace Windows with it. One problem I am now running into is to make the second screen working.

I have an Optiplex 990, which comes with an internal Intel 2000 Graphic Card and an ASUS ATI Radeon HD 6570. Each graphic card is connected to one 24" monitor.

When I start Ubuntu 12.04 from USB stick, the boot menu shows on the Intel monitor. Then the Ubuntu....-loading-logo appears on the second Ati monitor. Then the actual Ubuntu workspace loads on the Intel monitor again and the ATI monitor goes into power save mode.

Doing this I get:

lspci | grep VGA

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Turks [Radeon HD 6570]

enter image description here

Therefore the screen you see here is only the intel driven one. The ATi one is forgotten.

I ended up installing the ATI driver from their website. and went through the steps as described here:

After installing it, I still get the following:

ubuntu@ubuntu:~/Downloads$ fglrxinfo

display: :0  screen: 0
OpenGL vendor string: Tungsten Graphics, Inc
OpenGL renderer string: Mesa DRI Intel(R) Sandybridge Desktop 
OpenGL version string: 1.4 (3.0 Mesa 8.0.2)

Which is expected, as my ATI connected screen is disabled.

Taking a glance at /etc/X11/xorg.conf

Section "ServerLayout"
        Identifier     "aticonfig Layout"
        Screen      0  "aticonfig-Screen[0]-0" 0 0
EndSection

Section "Module"
EndSection

Section "Monitor"
        Identifier   "aticonfig-Monitor[0]-0"
        Option      "VendorName" "ATI Proprietary Driver"
        Option      "ModelName" "Generic Autodetecting Monitor"
        Option      "DPMS" "true"
EndSection

Section "Device"
        Identifier  "aticonfig-Device[0]-0"
        Driver      "fglrx"
        BusID       "PCI:1:0:0"
EndSection

Section "Screen"
        Identifier "aticonfig-Screen[0]-0"
        Device     "aticonfig-Device[0]-0"
        Monitor    "aticonfig-Monitor[0]-0"
        DefaultDepth     24
        SubSection "Display"
                Viewport   0 0
                Depth     24
        EndSubSection
EndSection

I don't know what else I could do. Is here any pro that could help me solving this issue?

Many Thanks,

share|improve this question
    
Did you get anywhere with this? I'm having a similar problem. I have one monitor connected to a HD5000 and another connected via VGA to my motherboard but only the monitor connected to the HD5000 is showing up. –  James Feb 3 '14 at 18:12
    
I found it impossible. I tried everything back then. I ended up buying another cable and connecting the Ati card directly to the second monitor. I was lucky that the Ati card had two digital outputs though. –  Houman Feb 3 '14 at 21:30
    
My card has two output on it, however the shape of the case is preventing me from using the VGA slot. Thank you anyway! –  James Feb 4 '14 at 10:03

1 Answer 1

You need to define your 2 screens in AMD soft.

  1. Open ATI driver application

    enter image description here

  2. and define your 2 screens display without any limit.

    amd settings

  3. and re-boot

share|improve this answer
    
Thanks. This would only work if both screens are attached to an AMD video card. In my case one is connected to the internal Intel Graphic card. Not sure if that would work. –  Houman May 16 '12 at 14:55

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.