Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

For some reason I have yet to understand, when I upgraded from 11.10 (working flawlessly) to 12.04, internet seems not to work after a while and the only solutions are either to reboot or to disable and enable wireless.

This is my network device, 02:00.0 Network controller: Intel Corporation Centrino Wireless-N + WiMAX 6150 (rev 67)

I could attach some of my latest logs but I don't know how to format that properly. This looks problematic (I changed the mac and SRC just in case):

lobato kernel: [ 9561.859976] wlan0: no IPv6 routers present

lobato kernel: [ 9563.341424] [UFW BLOCK] IN=wlan0 OUT= MAC=01:xx:xx:xx:xx:01:f4:ec:38:be:d6:3c:08:00 SRC=192.162.3.1 DST=224.0.0.1 LEN=32 
TOS=0x00 PREC=0xC0 TTL=1 ID=0 DF PROTO=2 

lobato kernel: [ 9564.764594] [UFW BLOCK] IN=wlan0 OUT= MAC=40:xx:xx:xx:xx:58:ec:55:f9:41:08:f7:08:00 SRC=192.162.3.124 DST=224.0.0.251 LEN=32 TOS=0x00 PREC=0x00 TTL=1 ID=13535 PROTO=2 

lobato NetworkManager[1379]: <info> (wlan0): IP6 addrconf timed out or failed.
share|improve this question

1 Answer 1

It looks like your connection is trying to get IPv6 DHCP from the router, but failing. Unless you want to configure your router for IPv6, you can edit the connection to not look for an IPv6 address:

  1. Click on the network-manager icon in the system tray.
  2. Click "Edit Connections".
  3. Click the "Wireless" tab.
  4. Select the network, and click "edit".
  5. Click the "IPv6 Settings" tab.
  6. Change the "Method" to "Ignore".
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.