Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

I have changed my default cursor theme to the DMZ black, but when my mouse hovers over any Skype window, it turns into DMZ white (only while hovering). When I try to take a screenshot of it, the cursor shows up as black on the image, which is rather weird.

Anybody who's got an idea how to fix it?

share|improve this question
    
I am quite sure that skype uses QT for window rendering, because of this you might have to change som qt/kde setting. But how I have no idea. –  Source Lab Nov 12 '10 at 0:54
    
yuck! I already disliked skype in ubuntu, now I absolutely hate it :| –  theTuxRacer Dec 3 '10 at 13:53
    
This doesn't happen for me. What versions are you using (skype and ubuntu)? –  David Oneill Dec 17 '10 at 17:18
add comment

4 Answers

up vote 9 down vote accepted

This is common problem with Skype, I've had it too. To fix it, you need to install kde's system-settings (sadly, no option for the cursor in qt-config, and it's probably not so trivial, or wise to edit the qt-config by hand). In KDE's system settings, choose the mouse option to change your Qt cursor theme.

Another possible fix is to change the default theme for your entire system. Run galternatives Install galternatives and change the x-cursor theme to the one you currently use.

share|improve this answer
    
The galternatives did the trick, and if I'm lucky, it'll fix another annoyance I've had: that the cursor changes briefly during login, even though I've changed the gdm-cursor theme to DMZ-black. Thanks a lot! –  Fraekkert Dec 17 '10 at 17:38
    
galternatives did the trick –  logcat Sep 26 '13 at 14:11
add comment

I'm using th Mint KDE 16 64 bit, and I install skype from software center, and have that problem. Then I run install command on terminal shell:

sudo apt-get install libxcursor1:i386

After that I reboot the computer, and it's done.

share|improve this answer
add comment

Strange, but on my system (13.04) the issue has been healed just through installation of libxcursor1:i386.

share|improve this answer
    
worked for me as well –  Rain Aug 15 '13 at 10:12
    
worked for me too, the simplest solution so far! –  Dmitry Pashkevich Mar 2 at 19:59
add comment

Maybe someone else would be also interested in another possible solution: when I installed Skype from Ubuntu repository (11.10) I also had the same issue - but I've tried downloading and installing Skype client from skype.com page and then after installing it - normal KDE settings applies on it as well...

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.