Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

This is what happened. I was using 12.04 beta. I was asked by update manager to make required updates, which I did. I shut down my pc that night and the next day I was not able to boot in xwindows or graphical interface. I tried several threads from this forum still was unsuccessful, so I decided to remove beta and do a fresh install of Ubuntu 12.04, which I did.

I went in windows 7, in disk management tool I deleted linux volume and swap volume. Then when I rebooted I was stuck with a grub rescue screen. I was not able to boot in windows 7. I went through several threads from this forum and elsewhere and learning that boot-repair (https://help.ubuntu.com/community/Boot-Repair) was the best option. I did that. I clicked on recommended repair and wolla!! I got my windows 7 back. So I decided to install Ubuntu 12.04 again. I did and when I rebooted I was not asked for OS options and was directly taken to windows 7. I tried this thread https://help.ubuntu.com/community/Grub2#Reinstalling_GRUB2 but I am still not able to go into ubuntu or get a boot loader screen. I guess my grub messed up pretty badly when I deleted linux on the first place.

My boot info summary http://paste.ubuntu.com/954260/

Your kindest suggestions will be helpful.

share|improve this question
    
Have you tried running boot repair again since you reinstalled Ubuntu? –  coversnail Apr 29 '12 at 6:11
    
yes. This bootinfosummary is post reinstall of ubuntu. which I have tried an hour ago. –  ubuntujeev Apr 29 '12 at 6:14
    
So while reinstalling grub2 when it comes to package configuration and asks where to place grub2. I should select sda instead of sdc. Is that what you are trying to tell me? @aking1012 –  ubuntujeev Apr 29 '12 at 6:21
    
Ok I will give it a try and come back to you. –  ubuntujeev Apr 29 '12 at 6:25
1  
I just did update-grub and grub-install /dev/sda and rebooted. Amazingly it worked. Thanks @aking1012 –  ubuntujeev Apr 29 '12 at 12:18

2 Answers 2

up vote 0 down vote accepted

Moving comments to an answer:

Grub2 is installed to sdc not sda. if you want it to magically find, it needs to be on the drive your motherboard defaults to. This in most cases is sda.

Under typical circumstances when installing grub2 it should be on /dev/sda.

You can do this from a liveCD or using the boot repair disks you found. I tend to favor a liveCD because I control exactly what is going on, but it lacks an easy-button.

share|improve this answer

Looking at bootinfo grab => Grub2 (v1.99) is installed in the MBR of /dev/sdc and looks at sector 1 of the same hard drive for core.img. core.img is at t his location and looks for (,msdos5)/boot/grub on this drive.

so now you are having a windows loader in MBR of your primary hdd(sda) ;perhaps u can try making sdc as your primary disk and try a boot (settings to be done in BIOS).If your ubuntu install is proper u will get in to this only.But for dual boot u need to chainload one or other

option1: u can use the windows loader to chainload grub using 3rd party softwares http://www.supergrubdisk.org/wiki/Howto_Boot_Grub_from_windows (Windows Vista (with easybcd help)

option2:re-install grub to MBR of sda and do an os-probe to chainload windows7

Have your rescue-disks handy!!

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.