Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

When I have no other programs running, compiz takes up at least 40% of my CPU.
Is this normal? If it is normal, is there anyway I could make this program take a smaller percentage?

share|improve this question
Definitely not normal. – Chan-Ho Suh Apr 29 '12 at 5:18
up vote 6 down vote accepted

Edit: As of Ubuntu 12.10 this is no longer an option, as Unity-2D was dropped with quantal.

I have the same issues with cpu usage because of compiz. My workaround was to switch session from Ubuntu to Ubuntu 2D.

ubuntu 2d

share|improve this answer
I actually did this shortly after asking, and it worked out really well for me. Everything's much smoother. – Jiskya May 28 '12 at 15:07
This is not normal, and switching to Unity 2D, when on a modern high end machine is no solution. The developers should really work this out as it is very annoying. – ECII Jun 10 '12 at 9:11
@ECII i agree with you, but while they fix it, unity 2d could be workaround for the issue. – Eugene Manuilov Jun 10 '12 at 16:17
How this can be a solution?. OP is wanting to use compiz with less CPU usages. In unity-2d there is no compiz. – Anwar Shah Jun 17 '12 at 17:24

I had the same problem that the CPU load went up to 70%~80% and that upset me for a long time after upgrading to 12.04 from 10.04.

And reset compiz settings to default or remove the ~/.compiz-1 & ~/.config/compiz-1 folders didn't work.

But after I uncheck the "Sync to VBlank" box under OpenGL in ccsm (CompizConfig Settings Manager), the CPU load drop to 1% immediately.

Hope this will help you and other guys...

Sorry for my poor expression (I'm a student from china).

share|improve this answer
Thank You, student from China :) Sync to Vblank helped me too. Warning: After Reset to defaults I had to change to console and type "unity --reset" and untick Sync to Vblank again. – user137000 Mar 2 '13 at 16:54
Whoa, that helped a lot here as well. Does that happen to be on a system that uses the nvidia closed-source drivers? – wump Jun 9 '14 at 9:07

Had the same problem. Compiz constantly at around 40% (AMD CPU, ATI 58xx, 12.04). Then i followed this post and CPU utilization dropped below 10%. Hope it helps.

EDIT with instuctions:

Just backup (rename) ~/.compiz-1 and ~/.config/compiz-1 directories and let them to be created again with the default settings (you'll need to logout and login back again).

mv ~/.compiz-1 ~/.compiz-1.BACKUP
mv ~/.config/compiz-1 ~/config/.compiz-1.BACKUP

After having restarted and confirmed that everything works as expected, you can simply remove these backups (unless you have a use for them).

rm -Rfv ~/.compiz-1.BACKUP
rm -Rfv ~/config/.compiz-1.BACKUP

It helps to do a unity --reset also

share|improve this answer
Can you put the actual answer here. – Anwar Shah Jun 17 '12 at 17:24
What actual question? – ECII Jun 17 '12 at 17:26
Oh, that was a typo. I meant answer. putting the answer directly here may be more useful – Anwar Shah Jun 17 '12 at 17:27

The new version of Compiz and the Unity plugin have major changes that make it behave differently. In my own case, I had to reset compiz settings to defaults in order to get it working appropriately after the upgrade to 12.04.

I have an ATI Radeon HD5750 card, and I really noted a great performance improvement (after fixing compiz) compared to 11.10.

share|improve this answer
  1. Install compizconfig-settings-manager. Run it by typing ccsm in the dash.

  2. In the application's main window, click on the bottom link with Preference label.

  3. In the Profile tab, click on Reset to default button.

  4. Logout and Login again.

Hope this will help

picture of Profile tab

share|improve this answer
Don't do this with 14.10. I don't know about earlier version of Ubuntu, but I just did this and it caused me to lose my window borders and the unity menu. Rebooting didn't fix it, I had to plugin my phone to get a files window to open, then browse to the terminal app to open it, then run a couple commands to fix the problem. – GregInWI2 Apr 15 '15 at 14:01

apparently there is a bug with ATI card base on this site:

based on that site there is a few step :

  1. install compizconfig-settings-manager (CCSM)
  2. navigate to opengl then change Texture Filter to Fast and uncheck sync to VBlank
  3. close CCSM then restart ubuntu

check in system monitor, hopefully compiz will not need a lot of CPU anymore.

share|improve this answer

I figured the same issue on ubuntu 15.04. My laptop was having lot of lag, and I saw that compiz was always up to 25% CPU load. I first searched around drivers but I finally found that compiz fall to 3% as soon as no webapp is opened. I used to use twitter and facebook with the native webapps (embeded in oxide).

Since I just use firefox, compiz does not climb upper than 5% CPU.

Hope it helps.

share|improve this answer

I figured out that on my laptop with NVIDIA 8600M GS graphics and proprietary nvidia-340 driver package, compiz was always using all the CPU it could get from a single core. With no other activity on my computer, this means a value close to 100% on one core, while the other takes care of all the other loads. Top also reports nearly 100% for compiz itself.

Of course, it seems a single thread stays active, so on a quad core PC, you would get 25% load, and 16% on a 6 core i7.

The whole computer was sluggish to the point of lagging for text input.

I ran "pilotes additionnels" (french language setting), the built-in ubuntu interface which installs proprietary driver, and I was offered a choice of NVIDIA driver versions, plus nouveau, the open source driver.

At the very end of the list, I noticed "nvidia-340-update", which is the same 340.96 proprietary NVIDIA driver, and I decided to give it a try. The 8600M GS is not supported in later driver releases. I let the installer compile everything, rebooted when asked to, and the high cpu usage from compiz was gone!

If it works for you, this solution fits the linux-restricted-modules infrastructure better than managing an NVIDIA driver manually. It replaces nvidia-340 by nvidia-340-update.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.