Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I have no other programs running, compiz takes up at least 40% of my CPU.
Is this normal? If it is normal, is there anyway I could make this program take a smaller percentage?

share|improve this question
3  
Definitely not normal. –  Chan-Ho Suh Apr 29 '12 at 5:18

6 Answers 6

up vote 4 down vote accepted

Edit: As of Ubuntu 12.10 this is no longer an option, as Unity-2D was dropped with quantal.

I have the same issues with cpu usage because of compiz. My workaround was to switch session from Ubuntu to Ubuntu 2D.

ubuntu 2d

share|improve this answer
    
I actually did this shortly after asking, and it worked out really well for me. Everything's much smoother. –  Jiskya May 28 '12 at 15:07
3  
This is not normal, and switching to Unity 2D, when on a modern high end machine is no solution. The developers should really work this out as it is very annoying. –  ECII Jun 10 '12 at 9:11
    
@ECII i agree with you, but while they fix it, unity 2d could be workaround for the issue. –  Eugene Manuilov Jun 10 '12 at 16:17
3  
How this can be a solution?. OP is wanting to use compiz with less CPU usages. In unity-2d there is no compiz. –  Anwar Shah Jun 17 '12 at 17:24

Had the same problem. Compiz constantly at around 40% (AMD CPU, ATI 58xx, 12.04). Then i followed this post http://askubuntu.com/a/127310/26508 and CPU utilization dropped below 10%. Hope it helps.

EDIT with instuctions:

Just backup (rename) ~/.compiz-1 and ~/.config/compiz-1 directories and let them to be created again with the default settings (you'll need to logout and login back again).

mv ~/.compiz-1 ~/.compiz-1.BACKUP
mv ~/.config/compiz-1 ~/config/.compiz-1.BACKUP

After having restarted and confirmed that everything works as expected, you can simply remove these backups (unless you have a use for them).

rm -Rfv ~/.compiz-1.BACKUP
rm -Rfv ~/config/.compiz-1.BACKUP

It helps to do a unity --reset also

share|improve this answer
    
Can you put the actual answer here. –  Anwar Shah Jun 17 '12 at 17:24
    
What actual question? –  ECII Jun 17 '12 at 17:26
    
Oh, that was a typo. I meant answer. putting the answer directly here may be more useful –  Anwar Shah Jun 17 '12 at 17:27

I had the same problem that the CPU load went up to 70%~80% and that upset me for a long time after upgrading to 12.04 from 10.04.

And reset compiz settings to default or remove the ~/.compiz-1 & ~/.config/compiz-1 folders didn't work.

But after I uncheck the "Sync to VBlank" box under OpenGL in ccsm (CompizConfig Settings Manager), the CPU load drop to 1% immediately.

Hope this will help you and other guys...

Sorry for my poor expression (I'm a student from china).

share|improve this answer
    
Thank You, student from China :) Sync to Vblank helped me too. Warning: After Reset to defaults I had to change to console and type "unity --reset" and untick Sync to Vblank again. –  user137000 Mar 2 '13 at 16:54
    
Whoa, that helped a lot here as well. Does that happen to be on a system that uses the nvidia closed-source drivers? –  wump Jun 9 at 9:07

The new version of Compiz and the Unity plugin have major changes that make it behave differently. In my own case, I had to reset compiz settings to defaults in order to get it working appropriately after the upgrade to 12.04.

I have an ATI Radeon HD5750 card, and I really noted a great performance improvement (after fixing compiz) compared to 11.10.

share|improve this answer
  1. Install compizconfig-settings-manager. Run it by typing ccsm in the dash.

  2. In the application's main window, click on the bottom link with Preference label.

  3. In the Profile tab, click on Reset to default button.

  4. Logout and Login again.

Hope this will help

picture of Profile tab

share|improve this answer

apparently there is a bug with ATI card base on this site: http://followthegeeks.com/compiz-is-consuming-too-much-cpu-heres-the-solution/

based on that site there is a few step :

  1. install compizconfig-settings-manager (CCSM)
  2. navigate to opengl then change Texture Filter to Fast and uncheck sync to VBlank
  3. close CCSM then restart ubuntu

check in system monitor, hopefully compiz will not need a lot of CPU anymore.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.