Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

my sony vaio cs33g microphone is working on windows7 but it does not work on Ubuntu, any suggestions ?

share|improve this question

closed as too localized by Luis Mar 14 '13 at 16:30

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center.If this question can be reworded to fit the rules in the help center, please edit the question.

1  
I assume you've checked volume control, sound properties and you are trying to record using "Sound Recorder". If you haven't, please do and explain what happens (e.g. "recorder doesn't acknowledge any sound input", etc) –  Umang Aug 6 '10 at 8:54

2 Answers 2

You can also test your microphone in the Sound Preferences.

  1. Click the Indicator Applet's sound icon and select 'Sound Preferences...'
  2. Select the 'Input' tab
  3. In the 'connector' drop down, select one of the microphones and speak. If it works you should see the 'input level' raise & change color.
  4. If it doesn't work, try raising the 'input volume'. Also make sure it's not muted.
  5. If it still doesn't work, try another option in the the 'connector' drop down.

Hopefully this helps. My mic wasn't working yesterday as well, and this is what I did to get it working.

share|improve this answer

I recommend testing your microphone with Audacity instead of gnome-sound-recorder, because sound recorder sometimes fails even when everything else is working. Here are some common solutions to microphone problems:

  1. The hardware profile sometimes defaults to one of the "Output" options, which disables the microphone. In sound prefs (Hardware tab), check to make sure the hardware profile is set to something that includes input. "Analog Stereo Duplex" is a good guess if you aren't sure.

  2. Check the input tab -- (a) make sure the mic is selected as your input device and (b) adjust the input volume to a reasonable level. Speak into the microphone and check the level indicator. If the level indicator shows a signal, then the microphone is working and the problem is with the program you're using to record.

  3. If the level indicator doesn't show anything, try installing the ALSA mixer (sudo apt-get install gnome-alsamixer) and play around with the input sliders (the ones with "Rec" check boxes underneath them).

  4. If all else fails, it's possible that Ubuntu just doesn't support your sound card. This is less common than it used to be, but it still happens sometimes.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.