Take the 2-minute tour ×
Ask Ubuntu is a question and answer site for Ubuntu users and developers. It's 100% free, no registration required.

When I updated to 11.04 I changed the desktop to Gnome, now with the new 12.04 I'd like to switch back to Unity. How do I do this? Thanks!

share|improve this question
add comment

4 Answers

I believe this has already been asked. How can I switch between gnome-shell and unity without logging off?

Open a terminal and type: unity --replace

share|improve this answer
    
This works great...but gnome returns on restart...and I was wanting Unity to be default desktop. (sorry for not phrasing question more clearly...did upgrade to 12.04 after work...excited but tired) –  Bob Wise Apr 29 '12 at 13:18
    
And I liked the option of using either desktop. –  Bob Wise Apr 29 '12 at 13:24
add comment

I think it depends on how you switched it... Have you tried clicking the Ubuntu icon by the login name at the login screen, then switch it to "Ubuntu"? If you could explain how you "changed the desktop to Gnome" in the first place, maybe we could see about reversing that change.

share|improve this answer
    
Just did, and re-started and Unity came up again...your help is much appreciated...thanks! –  Bob Wise Apr 29 '12 at 13:28
    
Good. Now, just for the record, cause that might be of help to other users which may have the same problem... Can you share how did you do that? –  Simón Apr 30 '12 at 22:53
add comment

just logout and select ubuntu on clicking setting icon and then login and you will have your unity environment set. Thats it.

share|improve this answer
    
Perfect solution...easy, quick, and it did what I was after. –  Bob Wise Apr 29 '12 at 13:22
add comment

Well... I guess this is a problem a lot of people is experiencing.

In my own case, I had customized compiz settings previous to the upgrade. And after upgrading from 11.10 to 12.04 compiz started to fail... hence no Unity, no launcher, no menu, no window frames... etc.

I assumed it was because of some personal compiz settings (although not sure which exact settings cause this), since I could login to the Guest account without problems, and there everything worked as expected.

So, I thought the only way to solve this was to reset compiz settings to defaults.

share|improve this answer
    
Hmm, will explore this also, seems to be another way to accomplish what I wanted. Thank you! –  Bob Wise Apr 29 '12 at 13:29
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.